Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
The moose likes EJB and other Java EE Technologies and the fly likes EJB problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "EJB problem" Watch "EJB problem" New topic

EJB problem

Dono Learn To Java

Joined: Mar 01, 2005
Posts: 1
hi all
I have a problem using Eclipse 3.0.1 using Lomboz and JBoss 4.0.1. I've tried to create EJB Project, but i get the message bellow when I'm doing "debug server". I've tried all possible modification on creating EJB by changing the path, the server but there are so many error message.

I need help from you to solve this problem. Thank's

10:47:08,019 INFO [Server] Starting General Purpose Architecture (GPA)...
10:47:10,262 INFO [ServerInfo] Java version: 1.4.2_04,Sun Microsystems Inc.
10:47:10,262 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.4.2_04-b04,Sun Microsystems Inc.
10:47:10,272 INFO [ServerInfo] OS-System: Windows XP 5.1,x86
10:47:12,555 INFO [Server] Core system initialized
10:47:22,430 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:log4j.xml
10:47:22,930 INFO [WebService] Using RMI server codebase: http://ppti-999:8083/
10:47:23,762 INFO [NamingService] Started jndi bootstrap jnpPort=1099, rmiPort=1098, backlog=50, bindAddress=/, Client SocketFactory=null, Server
10:47:23,942 ERROR [NamingService] Starting failed jboss:service=Naming
at org.jboss.naming.NamingService.startService(
at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(
at org.jboss.system.ServiceMBeanSupport.jbossInternalLifecycle(
at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at org.jboss.system.ServiceController$ServiceProxy.invoke(
at $Proxy0.start(Unknown Source)

10:58:14,095 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-
10:58:15,377 INFO [ChannelSocket] JK2: ajp13 listening on /
10:58:15,487 INFO [JkMain] Jk running ID=0 time=0/381 config=null
10:58:15,547 INFO [Server] JBoss (MX MicroKernel) [4.0.1sp1 (build: CVSTag=JBoss_4_0_1_SP1 date=200502160314)] Started in 3m:9s:653ms
I agree. Here's the link:
subject: EJB problem
jQuery in Action, 3rd edition