Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
The moose likes EJB and other Java EE Technologies and the fly likes problem!! No suitable driver Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "problem!! No suitable driver" Watch "problem!! No suitable driver" New topic
Author

problem!! No suitable driver

Sree kanth
Ranch Hand

Joined: Feb 02, 2005
Posts: 53
hi

I'm facin a strange problem.
When ever i execute a servlet or jsp or EJB with JDBc conncection, I am gettin an SQL Exception saying NO SUITABLE DRIVER. But if te same program is done in CORE JAVA there is no problem all DML operations are workin.
What may be te problem? Do i ave to change any configuration files.
Please help me as early as possible.
Thankyou,
Sree


Sree
Abhishek Asthana
Ranch Hand

Joined: Sep 08, 2004
Posts: 146
Hi Sree,
Which database are you using and what server? Please give more details so that I can help you.
Abhishek
Sree kanth
Ranch Hand

Joined: Feb 02, 2005
Posts: 53
Hi Abhishek
I am using j2ee server and SQL Server 2000.
Please help me this is very urgent.
arunij katiliyar
Greenhorn

Joined: Mar 09, 2005
Posts: 26
Hi ,
do you have the libraries for jdbc from SQL SERVer in the classpath of the webserver/appserver . The webserver/appserver might use a propertiery claspath setting when booting .please check this and lemme know .

If the webserver is weblogic , the classpath setting is in

weblogic_installroot/bin/setWLS

else if websphere then

installroot/bin/setCLASSPATH ( I think ??)

make sure that you append the path where libraries are present to their classpath and restart .


Arun
 
 
subject: problem!! No suitable driver
 
Similar Threads
mysql JDBC driver classpath problem.
applets with sql server
JDBC-ODBC bridge in J2EE 1.3
MySQL Error - no driver
problem,please help!