Meaningless Drivel is fun!*
The moose likes EJB and other Java EE Technologies and the fly likes Weblogic server problem. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Weblogic server problem." Watch "Weblogic server problem." New topic
Author

Weblogic server problem.

Ram Kumar Rengarajan
Greenhorn

Joined: Apr 28, 2005
Posts: 22
Hi,

I have installed weblogic server 7.0. It works fine. Server Started in Running mode. But If i restart or shutdown my system, I could not able to start the weblogic server again. I got this error. Can anyone help me for solve my problem.. Thanks..



***************************************************
* To start WebLogic Server, use a username and *
* password assigned to an admin-level user. For *
* server administration, use the WebLogic Server *
* console at :[port]/console]http://[hostname]:[port]/console *
***************************************************

C:\bea\user_projects\mydomain>"C:\bea\jdk131_06\bin\java" -hotspot -Xms32m -Xmx2
00m -Dweblogic.security.SSL.trustedCAKeyStore=C:\bea\weblogic700\server\lib\cace
rts -Dweblogic.Name=myserver -Dbea.home="C:\bea" -Dweblogic.management.username=
-Dweblogic.management.password= -Dweblogic.ProductionModeEnabled= -Djava.securi
ty.policy="C:\bea\weblogic700\server\lib\weblogic.policy" weblogic.Server
<Apr 29, 2005 4:32:35 PM IST> <Info> <Security> <090065> <Getting boot identity
from user.>
Enter username to boot WebLogic server:ram
Enter password to boot WebLogic server:
Starting WebLogic Server...
<Apr 29, 2005 4:32:41 PM IST> <Notice> <Management> <140005> <Loading configurat
ion C:\bea\user_projects\mydomain\.\config.xml>
<Apr 29, 2005 4:32:43 PM IST> <Error> <EmbeddedLDAP> <171516> <Could not get exc
lusive access to the embedded LDAP data files directory: .\myserver\ldap\ldapfil
es>
<Apr 29, 2005 4:32:43 PM IST> <Critical> <WebLogicServer> <000364> <Server faile
d during initialization. Exception:weblogic.server.ServiceFailureException: Coul
d not get exclusive access to embedded LDAP data files due to existing server
weblogic.server.ServiceFailureException: Could not get exclusive access to embed
ded LDAP data files due to existing server
at weblogic.ldap.EmbeddedLDAP.ensureExclusiveAccess(EmbeddedLDAP.java:89
9)
at weblogic.ldap.EmbeddedLDAP.initialize(EmbeddedLDAP.java:204)
at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:717)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:594)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:282)
at weblogic.Server.main(Server.java:32)
>
<Apr 29, 2005 4:32:43 PM IST> <Emergency> <WebLogicServer> <000342> <Unable to i
nitialize the server: Fatal initialization exception
Throwable: weblogic.server.ServiceFailureException: Could not get exclusive acce
ss to embedded LDAP data files due to existing server
weblogic.server.ServiceFailureException: Could not get exclusive access to embed
ded LDAP data files due to existing server
at weblogic.ldap.EmbeddedLDAP.ensureExclusiveAccess(EmbeddedLDAP.java:89
9)
at weblogic.ldap.EmbeddedLDAP.initialize(EmbeddedLDAP.java:204)
at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:717)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:594)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:282)
at weblogic.Server.main(Server.java:32)
>
***************************************************************************
The WebLogic Server did not start up properly.
Exception raised:
weblogic.server.ServiceFailureException: Could not get exclusive access to embed
ded LDAP data files due to existing server
at weblogic.ldap.EmbeddedLDAP.ensureExclusiveAccess(EmbeddedLDAP.java:89
9)
at weblogic.ldap.EmbeddedLDAP.initialize(EmbeddedLDAP.java:204)
at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:717)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:594)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:282)
at weblogic.Server.main(Server.java:32)
Reason: Fatal initialization exception
Throwable: weblogic.server.ServiceFailureException: Could not get exclusive acce
ss to embedded LDAP data files due to existing server
weblogic.server.ServiceFailureException: Could not get exclusive access to embed
ded LDAP data files due to existing server
at weblogic.ldap.EmbeddedLDAP.ensureExclusiveAccess(EmbeddedLDAP.java:89
9)
at weblogic.ldap.EmbeddedLDAP.initialize(EmbeddedLDAP.java:204)
at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:717)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:594)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:282)
at weblogic.Server.main(Server.java:32)

***************************************************************************


Ram..
Valentin Tanase
Ranch Hand

Joined: Feb 17, 2005
Posts: 704
Here there is one tip:
$BEA_HOME/user_projects/$mydomain/$myserver/ldap/ldapfiles
Under this folder you'll find a file named EmbeddedLDAP.lok. Remove it and restart your server.
Regards.


I think, therefore I exist -- Rene Descartes
Abhinav Srivastava
Ranch Hand

Joined: Nov 19, 2002
Posts: 349

Probably you are starting it before the older instance has completely shut down.
Ram Kumar Rengarajan
Greenhorn

Joined: Apr 28, 2005
Posts: 22
hi Valentin,

I tried to delete the file EmbeddedLDAP. But I could not able to delete it. I got this error message.

"Cannot delete EmbeddedLDAP.lok: It is being used by another person or program. Close any programs that might be using the file and try again".

What should I do?..

My colligue has installed the Weblogic. In his system server works fine. Even If he restart the system, it works fine.

What is the problem in my system?.. Pls help me..

Thanks..

Ram...
Rajendra Lodha
Greenhorn

Joined: Apr 28, 2005
Posts: 4
Close the command prompt where you are stopping the server and try to restart on a new prompt
Valentin Tanase
Ranch Hand

Joined: Feb 17, 2005
Posts: 704
You need to kill any process that uses this file and remove the file after that.
Regards.
Ram Kumar Rengarajan
Greenhorn

Joined: Apr 28, 2005
Posts: 22
hi Valentin,

Again thanks for ur help. Now my weblogic server works fine. Even I restart my machine, it works fine. I deleted the file, which was told by you. Thank u very much. Thanks a lot.

I am facing another one problem. I Cannot able to view the left frame of admin console. I got this error.

java.lang.classnotfoundexception: weblogic.management.console.applets.Navapplet

Pls help me..

Thanks in advance..
Valentin Tanase
Ranch Hand

Joined: Feb 17, 2005
Posts: 704
You're very welcome Ram.
As for this last error it's an applet error and has probably more to do with your client settings; not sure though. I�m sorry but this time I'm quite clueless.
Regards.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Weblogic server problem.