File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes EJB and other Java EE Technologies and the fly likes Extremely strange behaviour in my entity beans create method, please help!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Extremely strange behaviour in my entity beans create method, please help!!" Watch "Extremely strange behaviour in my entity beans create method, please help!!" New topic
Author

Extremely strange behaviour in my entity beans create method, please help!!

Derick Potgieter
Ranch Hand

Joined: Feb 19, 2004
Posts: 53
Morning all,

Quick roundup :
I have and entity bean(local), with a session facade(remote) over it. My database is DB2 on an as/400, running JBOSS 4.0.2.

All my create,delete,update`s off all the other beans are fine. so everything connection wize is working.

I had to add 2 fields to one of my existing entity beans, i updated the facade and DTO objects to reflect these changes and now i get the following

when i use this specific entity bean(and only this one) :
I write information to the database, the create works perfectly, and all looks fine. But as soon as i write the next record to the database with the following two fields values identical (origin, destination), these two fields in the record above gets set to null.

So the record currently being written is always saved correctly. But as soon as eather of these two fields (origin, dest) have the same value (and only if the value is identical to the record above) the record above seems to loose it`s value.

Now i know i dont have any code to do this in my app. So i have absolutly no idea where to go look for this.

Any ideas???


SCJP, SCJD, SCWCD, SCBCD (JEE)
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Extremely strange behaviour in my entity beans create method, please help!!