Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Petstore deploy fails

 
wayner moose
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to build and deploy petstore blueprints to Sun One. The build looks fine but on deploy I get this message with one of the .ear deploys:

deploy-opc:
[echo] deploying ../src/apps/opc/build/opc.ear
[exec] CLI171 Command deploy failed : Deploying application in domain fail
ed; No local string defined -- Inconsistent Module State
[exec] ; requested operation cannot be completed

What does this mmessage mean? What is the 'local string'. Oddly, the same deploy works fine on my office computer with exactly the same Ant version, classpath, OS, Path, etc.!

Wayner Moose
 
wayner moose
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I managed to solve this one. Just uninstalled Petstore and then deleted all the directories in C:\Sun\AppServer\domains\domain1\generated that pertain to Petstore. Then redeploy - works fine. It is a small server bug that sometimes fails to delete these directories!

Once deployed I started getting null pointers on an old name for the computer - I renamed it a few months ago. Apparently Sun One grabs the computer name on the install and so I had to reinstall Sun One to fix it. First tried changing config and property files to no avail, so reinstalled and then the null pointers disappeared.

Wayner
 
Consider Paul's rocket mass heater.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic