This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes EJB and other Java EE Technologies and the fly likes installation problems Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "installation problems" Watch "installation problems" New topic
Author

installation problems

edem morny
Greenhorn

Joined: Feb 23, 2006
Posts: 2
i'm trying to install j2ee 1.3 on my system. i'm using the Head First EJB to study for the SCBCD. according to instructions, i'm to set the J2EE_HOME and Path variables to the directory i installed it and the bin directly respectively, which i've done a million and one times but still not been able to run commands at the command prompt. this is the message i get when i try this.

'C:\Program' is not recognised as an intenal or external command, operable program or batch file.

what am i doing wrong? cos i don't even know where that 'C:\program' is coming from, cos i installed it in c:\j2eesdk1.3.1 and the environment variables reflect that. I can't use j2ee 1.4 cos the exam is on the 1.3 version.


As Always<br />Edem
Chandra Sagi
Ranch Hand

Joined: May 05, 2005
Posts: 162
Are there any other files or folders set in your classpath which are under C:\Program Files\...., The error could be the space in between "Program and Files". It might be the error. You either could replace it with Progra~1 or enclosing it in quotes like "C:\Program Files". This may be of some help to you.

Thanks
Chandu
edem morny
Greenhorn

Joined: Feb 23, 2006
Posts: 2
hi, thanks for he tip. my J2SE installation was to C:\Program Files\... and after uninstalling and reinstalling to C:\Java\.. it worked. i think as u said it was the space between the "Program" and "Files" that was the problem.

However, i'm now getting a list of errors when i type "j2ee -verbose" beginning with

Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/corba/se/inte
rnal/util/IdentityHashtable
at com.sun.corba.ee.internal.javax.rmi.CORBA.Util.<clinit>(Util.java:87)

and a host of other errors. Can anybody else give me any idea what this is about? i'll be very grateful.

Edem
 
wood burning stoves
 
subject: installation problems
 
Similar Threads
Trouble Installing J2EE 1.3 SDK in Windows 7
J2EE and XP issues
Problem with j2ee running with space directory
can you run J2EE RI with JDK 1.5?
j2ee program not recognized