Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

jboss not able to run BMP Bean

 
shashi nela
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I have developed a BMP bean and i have deployed the jar in the default directory of JBoss. But it is not able to load the into memory.

Is it that it accepts only ejb3.0 spec.

I am usig ejb 2.0 and jboss4.0 application server.

it is not able to load the file into memory.

Al my xml files are ok.

regards,
shashi
 
Jaikiran Pai
Marshal
Pie
Posts: 10444
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i have deployed the jar in the default directory of JBoss

You should place the jar in %JBOSS_HOME%/server/default/deploy directory.

Is it that it accepts only ejb3.0 spec.

I am usig ejb 2.0 and jboss4.0 application server.


You can use Ejb-2.0 with JBoss-4.0 without any issues.

it is not able to load the file into memory.


Do you mean to say, the bean is not deployed?
 
shashi nela
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
yes. When i deploy the session bean or MDB the container automatically loads into memeory but this BMP bean it is not loading in memory.
 
Don't get me started about those stupid light bulbs.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic