my dog learned polymorphism*
The moose likes EJB and other Java EE Technologies and the fly likes InvalidClassException + incompatible: stream classdesc serialVersionUID Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "InvalidClassException + incompatible: stream classdesc serialVersionUID" Watch "InvalidClassException + incompatible: stream classdesc serialVersionUID" New topic
Author

InvalidClassException + incompatible: stream classdesc serialVersionUID

Parameswaran Thangavel
Ranch Hand

Joined: Mar 01, 2005
Posts: 485
hi all
in my project i am referring to the services for any backend opearation.
here when i tried to invoke a service i got the below mentioned exception.


java.io.InvalidClassException:
com.SearchCriteria; local class incompatible: stream classdesc serialVersionUID
= -998833680058290168, local class serialVersionUID = 29702


I am able to figure out the problem is with in the serialUid but donno whats the exact root cause of the problem

Any help would be appreciated.
Mark Spritzler
ranger
Sheriff

Joined: Feb 05, 2001
Posts: 17249
    
    6

Either a different version of the JVM versus what you compiled your code in, or the class is loaded in a different classloader that your app doesn't have access to.

Mark


Perfect World Programming, LLC - Two Laptop Bag - Tube Organizer
How to Ask Questions the Smart Way FAQ
Senthil S Kumar
Greenhorn

Joined: Aug 13, 2006
Posts: 10
If serialVersionUID is not explicitly defined in com.SearchCriteria, you will get this exception if your version of com.SearchCriteria is different from the service you are refering to.

Make sure you get the latest client library from your service provider.
[ August 13, 2006: Message edited by: Senthil S Kumar ]
 
 
subject: InvalidClassException + incompatible: stream classdesc serialVersionUID
 
Similar Threads
Deployment errors in JBoss5.1
Weblogic 7 with jdk 1.6 - Does it support jdk 1.6?
Error using JBoss5.0.0GA
serialVersionUID error message when executing swing based application from netbeans
jasper reports -Plz help me out