Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Xdoclet-Eclipse configuration

 
Felix Uzoukwu
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I will most appreciate it if someone could tell me what I am doing wrong.
I downloaded Eclipse and unzipped it in my favorite location, thereafter I
installed JBoss-Eclipse IDE which comes with Xdoclet.The problem is that
if I right-click a project and select properties --> xdoclet Configuration
I keep getting this error message "The currently displayed page contains
invalid values". I have re-installed eclipse many time with different version but I keep getting the same error.
Any idea will be most welcome
Thank you in advance
 
Forrest Xu
Ranch Hand
Posts: 92
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I got the same problem when I use eclipse 3.2.2, jboss-4.2.0.GA and ubuntu.
Can any one solve the problem?

Thanks,
 
Sunil Dixit
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Please make it sure that you have xdoclet on you box and XDOCLET_HOME env. variable is pointing to that directory.
Don't forget to include xdoclet bin director location in your PATH env. variable.

Sunil Dixit
 
Forrest Xu
Ranch Hand
Posts: 92
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The problem is solved. Eclipse 3.2 should work together with jboss IDE 2.0.0.
Eclisee 3.1 should work together with jboss IDE 1.5,1.6.
I used Eclipse 3.2 and jboss IDE 1.6, it makes xdoclet can not work properly.
Now it works fine.
Thank you for your help
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic