This week's book giveaway is in the Android forum.
We're giving away four copies of Head First Android and have Dawn & David Griffiths on-line!
See this thread for details.
The moose likes EJB and other Java EE Technologies and the fly likes Jboss Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Head First Android this week in the Android forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Jboss" Watch "Jboss" New topic
Author

Jboss

Sandip Sarkar
Ranch Hand

Joined: Nov 25, 2007
Posts: 55
Hi All,

Have installed JBOSS 4.2.2 GA.
My java is installed in C: drive and jboss in drive F:

The classpath is set as follows :

JAVA_HOME:C:\Program Files\Java\jdk1.5.0\bin
JBOSS_HOME:F:\jboss-4.2.2.GA\bin
CLASSPATH:C:\Program Files\Java\jdk1.5.0\bin;F:\jboss-4.2.2.GA\bin\run.jar

Still, whenever i go to the F drive Jboss folder and into the bin folder in command prompt and try "run.bat"...nothing happens.No errors...nothng.
What am i supposed to do?
Please guide.

Thanks,
Sandip
Scott Selikoff
author
Saloon Keeper

Joined: Oct 23, 2005
Posts: 3740
    
  10

You shouldn't need to add run.jar to the classpath, you should just need to be in the bin directory (from a command prompt) when you issue the run.bat command. I'd play around with the bat file (such as throwing echo hello world around) to see where its dying. Debugging isn't just restricted to java source code, but is a valuable skill anywhere.


[OCA 8 Book] [Blog]
Sandip Sarkar
Ranch Hand

Joined: Nov 25, 2007
Posts: 55
Thnaks Scott.
Let me try my hands a bit further.
But did you find any wrong parameters in my setting except the jar thing.

Thanks,
Sandip
Scott Selikoff
author
Saloon Keeper

Joined: Oct 23, 2005
Posts: 3740
    
  10

Can't really answer that without knowing how your computer is configured. You can put directories anywhere really.
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10439
    
176

JAVA_HOME:C:\Program Files\Java\jdk1.5.0\bin


Incorrect JAVA_HOME. It should be C:\Program Files\Java\jdk1.5.0


[My Blog] [JavaRanch Journal]
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Jboss
 
jQuery in Action, 3rd edition