aspose file tools*
The moose likes EJB and other Java EE Technologies and the fly likes Tomcat Server : Error filterStart Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Tomcat Server : Error filterStart" Watch "Tomcat Server : Error filterStart" New topic
Author

Tomcat Server : Error filterStart

kasi pandian
Greenhorn

Joined: Feb 01, 2008
Posts: 12
Hi Friends
My application is working in my old machine. Then I tried to configure the same applicatio in new machine I'm getting the following errors when I deployed in tomcat server.

Mar 30, 2008 6:48:19 PM org.apache.catalina.core.StandardContext start
SEVERE: Error filterStart
Mar 30, 2008 6:48:19 PM org.apache.catalina.core.StandardContext start
SEVERE: Context startup failed due to previous errors.

But my aplication still working in old machine. And the new machine also has the same configuration of old machine.
Java version 1.4.,Tomcat 5.0, Struts 1.1, Spring 2.0, DB2 8.2
And my filter configuration in Web.xml
<filter>
<filter-name>FormLoginFilter</filter-name>
<filter-class>
com.anfcorp.vendorpayment.authentication.FormLoginFilter
</filter-class>
</filter>
<filter-mapping>
<filter-name>FormLoginFilter</filter-name>
<url-pattern>/j_security_check</url-pattern>
</filter-mapping>
Could you help me out to solve this problem. I'm not able to find out the error, because the same file working fine in my old machine.
Thank you.

Regards
Kasipandian.R
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 41793
    
  62
My impression was that Tomcat doesn't support filtering j_security_check.


Ping & DNS - my free Android networking tools app
kasi pandian
Greenhorn

Joined: Feb 01, 2008
Posts: 12
j_security_check is working in my old machine. And I'm using Tomcat server only in my old machine.
kasi pandian
Greenhorn

Joined: Feb 01, 2008
Posts: 12
I found the solution. In my eclipse is showing the version jdk1.5 and tomcate jdk version is 1.4. I configured the same version. Now It worked.
Regards
Kasi
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tomcat Server : Error filterStart