*
The moose likes EJB and other Java EE Technologies and the fly likes Error while executing Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Error while executing" Watch "Error while executing" New topic
Author

Error while executing

Sweeti Reddy
Greenhorn

Joined: Jun 10, 2008
Posts: 3
I tried to change a feature in EJB file i added one method and try to test through frontend for that feature. I get below error:
I am using Eclipse and Ant and deploying the application in Weblogic. Can anyone help me out how do i test where in application it is getting stuck like in case can i put some print statement..??

Error 500--Internal Server Error
java.lang.NoSuchMethodError: gov.bls.cpi.jcs.ejb.CurrentStatus.getGroupJobSchedules()Ljava/util/Vector;
at gov.bls.cpi.jcs.struts.ShowScheduleController.perform(ShowScheduleController.java:69)
at org.apache.struts.action.ActionServlet.processActionPerform(ActionServlet.java:1786)
at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1585)
at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:491)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:743)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:223)
at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:125)
at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:283)
at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:175)
at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3245)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2003)
at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:1909)
at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1359)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:181)
Amit M Tank
Ranch Hand

Joined: Mar 28, 2004
Posts: 257
Hi,

What is this class -> CurrentStatus? Is it your SessionBean or your Remote/Local Interface?

Are you using EJB2 or EJB3?

Do you have the latest client jar(which has the class with the new method) in your war?
[ June 10, 2008: Message edited by: Amit M Tank ]

Amit Tank
Linked In
Sweeti Reddy
Greenhorn

Joined: Jun 10, 2008
Posts: 3
Thanks. Amit for your instant reply.

It got resolved. I was compiling in Eclipse through ANT but then when i checked the class and jar files the date was older not the time i did compiling....so cleaned up and recomipling a fresh. So now it started working....that's the reason it was giving the same error even after many changes to the code.

Thanks.
Amit M Tank
Ranch Hand

Joined: Mar 28, 2004
Posts: 257
Cool. Enjoy!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error while executing