wood burning stoves 2.0*
The moose likes EJB and other Java EE Technologies and the fly likes Using Sun's Migration Tool... Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Using Sun Watch "Using Sun New topic
Author

Using Sun's Migration Tool...

Larry Hack
Greenhorn

Joined: Aug 15, 2008
Posts: 7
I have been handed a project where the primary requirement is to convert a Websphere/DB2 application to either Sun App server(or JBoss)/Apache/M$ SQL Server or some other DB like mySQL.

The first item I undertook was to get the code (jar files, ear files, etc) and the DDL files for the database. Next, I downloaded and setup Eclipse for J2EE development, installed Sun's App Server, downloaded the Sun Migration Tool and followed the instructions to enable it to work within the App Server environment. As a test, I randomly grabbed a JAR file from the pile of code to see if it would run through the Migration tool. Of course, it threw an exception... but, I'm at a loss as to what I need to do to move forward from this point. If anyone has any idea of how to do a migration from Websphere to Sun App Server or JBoss, I sure would appreciate some pointers... The exception:


Thanks,

Da Liz
Scott Selikoff
author
Saloon Keeper

Joined: Oct 23, 2005
Posts: 3712
    
    5

"Lounge Lizard"

Please review The JavaRanch Naming Policy and update your name appropriately. In particular, names on the JavaRanch must not be obviously fictitious.

-Scott


My Blog: Down Home Country Coding with Scott Selikoff
Larry Hack
Greenhorn

Joined: Aug 15, 2008
Posts: 7
So SORRY!!!

I had no clue. I always create a "Lounge Lizard" entity on all forums everywhere when I have a need to communicate, to help, or to ask for some assistance. This is a FIRST... I'll have to agree to disagree with your rules, but I will comply and will not invite flames by discussing my opinion to those who are most likely to be argumentative and strive to have a need to express disdain at such flagrant disrespect to some obscure attempt at forced conformity and dubious professionalism...

And, yes - Larry Hack >>is<< my REAL NAME. I live in Chicago - look me up... If this isn't good enough, then I could create something like John Smith if it'll satisfy you...

So... if this issue is settled, can we get back to my original post and can someone please take a look at the error message and point me in the right direction???

Da Lizard
Larry Hack
Greenhorn

Joined: Aug 15, 2008
Posts: 7
As an added bit of info, I think I should provide some more insight. I only have the application JARs and Websphere EARs for the applications I am tasked to convert. I do not have any of the websphere specific xml files or configs for the app I've been handed. I have successfully ran each of the EARs through the Sun App Server's verifier - getting all ZEROs indicating no errors. But, I'm still not clear on how to go forward with the migration tool. I apparently am missing something because I do not have the websphere DDs for these EAR files (though I assume they are embedded) or something. I consistently get the error:


when trying the migration tool. I am thinking I
perhaps did not set up something correctly???

for example: ASMT instructions on Sun website indicates adding entries to
the domain.xml file (without being very clear on how or on syntax) - I
made some assumptions and have the following entry in the java-config tag:



I tried both with and without commas in the classpath-suffix element, but
in either case I get the same error message... Any idea what I am doing
wrong with the migration tool?

Da Lizard
Larry Hack
Greenhorn

Joined: Aug 15, 2008
Posts: 7
** bump ** still having this issue... and am pulling hairs out (losing more than gaining these days...) trying to figure out why the migration tool starts out fine then craps.

I decided to uninstall everything and create a whole new install of the latest j2EE JDK (since my original install had stuff inside of c:\Program Files\Java - and I wanted to eliminate tricky issues with having a space in the path). So, after uninstall and deleting all Java, I went through the registry on my dev machine and did a search for "c:\Program Files\Java" and replaced them all with "c:\java" - the new location for java stuff to be installed - then reinstalled everything anew.

then I tried migrating an ear that was a web app...


Looks slightly different, but in general, I am still getting the same old stuff as in the previous posting... Maybe the strange syntax in the first line of the exception is the clue but I can't find this in my code and am wondering if anyone has ever seen anything like this before? Also, I'm noting that all references in the exception path to any sun.iasmt.* classes are "Unknown Source"... perhaps another clue to something not defined or configured somewhere; but what and where? I just don't know where to look...

BTW - the code I am working on converting is from a Websphere 5.1 runtime environment and I have no access to the server that the files were exported from.

Da Lizard
 
 
subject: Using Sun's Migration Tool...