wood burning stoves*
The moose likes Java in General and the fly likes Enabling SSL support in JWS2.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Java in General
Bookmark "Enabling SSL support in JWS2.0" Watch "Enabling SSL support in JWS2.0" New topic
Author

Enabling SSL support in JWS2.0

thanga babu
Greenhorn

Joined: Mar 20, 2001
Posts: 3
Hi there,
How do I enable SSL support(https) in JWS2.0. I used the authstore utilility and created a new key (with the New certificate name ssl-RSA-default, 1024-bit key size, and the type as MD5-with-RSA and valid period of 90 days) all default. Now when I access the server with the address https://solaris2:7070/, the netscape throws up the error "Cannot communicate with server because there is no common encryption algorithms".
My administration console(at port 9090) shows that secure service is running perfectly. Still I get the same error when I try to access the secure service. But when I do the same steps for JWS1.1.3, ssl support is enabled perfectly. I dont know where or what I missed. Pls get me out of this.
Thanks in advance and regards,
P.Thanga Babu.
ky xxx
Greenhorn

Joined: Jun 09, 2003
Posts: 1
i had the same result to a different problem... perhaps this might help you out.
it turned out my keystore only had one entry in it... and it needed the trusted cert to work....
heres my keystore from scratch
------------
keytool -genkey -alias j2ee -keyalg RSA -keystore ./.keystore
/usr/local/ssl/misc/CA.sh -newca
/usr/local/ssl/misc/CA.sh -newcert
keytool -import -alias rug -file demoCA/cacert.pem -keystore ./.keystore
openssl x509 -in newreq.pem -out newreq2.pem
keytool -import -trustcacerts -file newreq2.pem

.hope this helps
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Enabling SSL support in JWS2.0
 
Similar Threads
configuring ssl for apache+openssl+tomcat
SSL problem with JBOSS AS
"Seam in Action" source code problem: SSL error when try to login "/open18"
cannot restart tomcat
SSL enabling in JWS 2.0