aspose file tools*
The moose likes Java in General and the fly likes my loader not working Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Java » Java in General
Bookmark "my loader not working" Watch "my loader not working" New topic
Author

my loader not working

Karthik Guru
Ranch Hand

Joined: Mar 06, 2001
Posts: 1209
hi all,
i just tried extending java.lang.ClassLoader.
Then i tried loading the same class (TestLoader) using my loader as mentioned in javageeks.com
But the class loader that loaded TestLoader is getting used again.
TestLoader's findClass is'nt getting called at all!
I have the code here.
findClass just opens the .class file and reads in the bytes.
can comeone suggest something as to why the second tiem around my sutom class laoder did'nt get used.

regards
karthik.
import java.io.*;
public class TestLoader extends ClassLoader{
protected TestLoader(){
super(TestLoader.class.getClassLoader());
System.out.println("TestLoader");
}
public Class findClass(String name) throws ClassNotFoundException{
String file = "d:\\java\\ClassLoaders" + name + ".class";
byte[] classBytes = null;
Class retClass = null;
try{
FileInputStream fis = new FileInputStream(file);
classBytes = new byte[fis.available()];
fis.read(classBytes);
retClass= defineClass(name,classBytes,0,classBytes.length); }catch(Exception e){
e.printStackTrace();
throw new ClassNotFoundException("class not found");
}
return retClass;
}

public static void main(String[] args)throws Exception{
TestLoader loader = new TestLoader();
System.out.println(loader.getClass().getClassLoader());
TestLoader l = null;
Class c=loader.loadClass("TestLoader");
l = (TestLoader)c.newInstance();
System.out.println(l.getClass().getClassLoader());

}
}
Karthik Guru
Ranch Hand

Joined: Mar 06, 2001
Posts: 1209
ok this is what i found.
Since the TestLoader is in the same directory and in classpath, it got loaded by the parent loader.
if it's not the case then it seems our loader gets a chance to load the class?. I verified this.
can someone correct me??
am not able to verify the claim by ted nedward with this code!
is there a way to get our classloader to load a class present in the classpath?
karthik.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: my loader not working