aspose file tools*
The moose likes Java in General and the fly likes jdk 1.3 on NT 4 compiling problems, please help Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Java » Java in General
Bookmark "jdk 1.3 on NT 4 compiling problems, please help" Watch "jdk 1.3 on NT 4 compiling problems, please help" New topic
Author

jdk 1.3 on NT 4 compiling problems, please help

Rebecca Xiao
Greenhorn

Joined: Oct 02, 2001
Posts: 1
I am using jdk 1.3(bundled with jbuilder personal edition 5) on NT, Tomcat, Struts and Oracle JDBC to develop an application.
I have included a "." at the end of my classpath configuration, however, the compiler refused to read anything in the current directory. Not even when I use "import ..." to explicitly include the classes in the same package(directory). Seems DC Dalton had the same problem on Windows 2000. I tried to copy the working directory into the classpath, still doesn't work.
Any body had the same problem before, your timely input will be deeply appreciated.
Sean MacLean
author
Ranch Hand

Joined: Nov 07, 2000
Posts: 621
You probably have a couple of classes/packages with the same name in you classpath. This seem to happen a lot with oracle and xml packages for some reason. It also seems to reveal itself if you use a dot in your classpath. Try putting the dot at the begining of the classpath or, better yet, remove it altogether and specify the dot when you run the application
java -classpath $CLASSPATH:. MyApp
Hope this helps.
Sean
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: jdk 1.3 on NT 4 compiling problems, please help