GeeCON Prague 2014*
The moose likes Java in General and the fly likes Help!!! Error 1335 when installing J2SE SDK 1.4.2_0X Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Java » Java in General
Bookmark "Help!!! Error 1335 when installing J2SE SDK 1.4.2_0X" Watch "Help!!! Error 1335 when installing J2SE SDK 1.4.2_0X" New topic
Author

Help!!! Error 1335 when installing J2SE SDK 1.4.2_0X

Steve Hart
Greenhorn

Joined: Feb 07, 2004
Posts: 2
Hi, I'm having serious trouble trying to install the Java 2 SDK onto my
PC.

I have tried installing 2 different versions;
j2sdk-1_4_2_03-windows-i586-p, and
j2sdk-1_4_2_04-windows-i586-p.
Both are the offline installation versions which I burned to separate
CD-ROMs in the last 4 months or so. Whenever I try to install either version,
I get the following error message during the "copying of files" stage of the
installation process:

"Error 1335. The cabinet file 'Data1.cab' required for this installation is
corrupt and cannot be used. This could indicate a network error, an error
reading from the CD-ROM, or a problem with this package."

The system I am trying to install it on is an Athlon 2600 with 256mb of RAM,
running Win XP Home Edition with Service Pack One.
The strange thing is, is it that it is only this PC which the problem occurs
on. I have successfully installed the 1_4_2_03 version of the
SDK onto my (rather antiquated) laptop, which has an AMD K6 400MHz, 96mb of
RAM, and running Windows 98. Also, I have just successfully installed the
1_4_2_04 version onto another different PC, which has an AMD K6 450MHz,
96mb of RAM and running Windows ME. Both of these versions were installed off
the very same CDs that are causing me all the problems mentioned above with my
PC running XP, so it suggests that there is no problem of corruption of the
installation files.

I have only managed to find information about this problem on a couple of
other sites, and I have tried every one of the suggestions that people in
a similar predicament have tried. These failed attempts include:

- Performing a 'clean boot' before installing the SDK.
- Swapping the slots that the PC's memory modules are in.
- Format of hard drive and complete re-installation of Windows.

I really am at a complete loss as to how to get Java up and running on my PC,
so if anyone out there knows how to fix the problem, please, please let me
know.

Thanks,
Steve.
Liam Tiarnach
Ranch Hand

Joined: Aug 06, 2004
Posts: 51
Aside from the possibility that both your PC and XP install are bad, have you tried directly downloading the SDK from Sun's site to your PC and install it that way ?

Though it seems unlikely, there maybe a problem with you CDROM drive or its drivers, so downloading via Internet and installing it that way may solve your issue and if it works, it will let you know that there is something wrong with either the CD, the CDROM, or the CDROM drivers...

Try it, and see what happens...


- Liam...<br />- ' He who never sleeps... '
Kate Head
Ranch Hand

Joined: Oct 31, 2002
Posts: 67
Hi there,
I know that the Windows installation is rather large at 51Mb but you need to download this one " Windows Offline Installation, Multi-language (j2sdk-1_4_2_05-windows-i586-p.exe, 51.09 MB)" to your hard disk and then install it - the other option works like IE download in that a "starter" is downloaded to your hard disk and then that starts the main program download so you need an internet connection for that to complete.
Or it might be worth copying your original CD to a new one at a slower speed?
hth
All the best,
Kate!!
[ August 06, 2004: Message edited by: Kate Head ]
Steve Hart
Greenhorn

Joined: Feb 07, 2004
Posts: 2
I have finally managed to get Java installed on my machine!!!
I downloaded the latest version of the SDK from Sun's site, but this still produced the exact same errors at first. After several unsuccessful attempts, I tried again, but on the screen which asks you which somponents you want to install, I just selected "Development Tools". To my joy, this worked. I then ran teh installer again, but this time just installed the JRE, and this worked this time as well.
I don't know why this method worked, but it did, and I can finally stop pulling my hair out!
Katie Irish
Greenhorn

Joined: Aug 29, 2004
Posts: 1
Steve,

I see that you've already managed to work around this problem but, I wanted to tell you what I've experienced with "error 1335".

Microsoft has a related article on this in their knowledge base ...http://support.microsoft.com/?kbid=314810

In my case it was "Method 2" that solved the problem. I reset the memory allocation in the Boot.ini file to 256 and the install completed with out any problems!! Now, I'm using WIN2000 and I only know enough to be dangerous sometimes so it took me 2 hours to determine the whereabouts of my msconfig utility (it does't come w/W2K it appears) and then find one I could use but ... it was worth it :-)

In your case you essentially got around the memory issue by only installing the capabilities one at a time - therefore putting less demand on the memory.

Good luck ...

MS Knowledge Base
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Help!!! Error 1335 when installing J2SE SDK 1.4.2_0X