aspose file tools*
The moose likes Java in General and the fly likes Extremely strange behaviour in my entity beans create method, please help!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Java in General
Bookmark "Extremely strange behaviour in my entity beans create method, please help!!" Watch "Extremely strange behaviour in my entity beans create method, please help!!" New topic
Author

Extremely strange behaviour in my entity beans create method, please help!!

Derick Potgieter
Ranch Hand

Joined: Feb 19, 2004
Posts: 53
Morning all,

Quick roundup :
I have and entity bean(local), with a session facade(remote) over it. My database is DB2 on an as/400.

All my create,delete,update`s off all the other beans are fine. so everything connection wize is working.

Now when i use a specific entity bean(and only this one) :
I write information to the database, the create works perfectly, and all looks fine. But as soon as i write the next record to the database with the following two fields values identical (origin, destination), these two fields in the record above gets set to null.

So the record currently being written is always saved correctly. But as soon as eather of these two fields (origin, dest) have the same value (and only if the value is identical to the record above) the record above seems to loose it`s value.

Now i know i dont have any code to do this in my app. So i have absolutly no idea where to go look for this.

Any ideas???


SCJP, SCJD, SCWCD, SCBCD (JEE)
Geoffrey Falk
Ranch Hand

Joined: Aug 17, 2001
Posts: 171
    
    1
Try posting your code.


Sun Certified Programmer for the Java 2 Platform
 
 
subject: Extremely strange behaviour in my entity beans create method, please help!!