This week's book giveaways are in the Refactoring and Agile forums.
We're giving away four copies each of Re-engineering Legacy Software and Docker in Action and have the authors on-line!
See this thread and this one for details.
Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Extremely strange behaviour in my entity beans create method, please help!!

 
Derick Potgieter
Ranch Hand
Posts: 53
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Morning all,

Quick roundup :
I have and entity bean(local), with a session facade(remote) over it. My database is DB2 on an as/400.

All my create,delete,update`s off all the other beans are fine. so everything connection wize is working.

Now when i use a specific entity bean(and only this one) :
I write information to the database, the create works perfectly, and all looks fine. But as soon as i write the next record to the database with the following two fields values identical (origin, destination), these two fields in the record above gets set to null.

So the record currently being written is always saved correctly. But as soon as eather of these two fields (origin, dest) have the same value (and only if the value is identical to the record above) the record above seems to loose it`s value.

Now i know i dont have any code to do this in my app. So i have absolutly no idea where to go look for this.

Any ideas???
 
Geoffrey Falk
Ranch Hand
Posts: 171
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try posting your code.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic