This week's book giveaway is in the Clojure forum.
We're giving away four copies of Clojure in Action and have Amit Rathore and Francis Avila on-line!
See this thread for details.
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Icons and a Label

 
David Crossett
Ranch Hand
Posts: 102
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can anyone tell my why my icon isn't showing up? I have the .gif file copied to the main directory, the class directory, and the src directory (just to be safe). I thought that I only needed th .gif in the .class folder (the same directory the program is running from). Anyway, all I see is test with no icons.

thanks!
 
Jose Botella
Ranch Hand
Posts: 2120
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi I cannot see anything wrong in the code. Try with another image file.
 
Brian Pipa
Ranch Hand
Posts: 299
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
to help figure out what's going on, use the full path to the image (just for testing) and see if that works. that will tell you if it's not finding the image or not. i bet you have it in a place that the vm can't find it. try putting it in the dir you are running from instead of hte place where the classes are.
you should probably put your code and the image in a .jar file - then it is easy to load the image with something like:

brian
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic