aspose file tools*
The moose likes Swing / AWT / SWT and the fly likes Keyboard shortcuts for 'Menu bars in an Applet' not working!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Java » Swing / AWT / SWT
Bookmark "Keyboard shortcuts for Watch "Keyboard shortcuts for New topic
Author

Keyboard shortcuts for 'Menu bars in an Applet' not working!!

Rohini Juneja
Greenhorn

Joined: Aug 20, 2004
Posts: 2
Hi,

I am trying to have shortcuts to the menu bar items which is part of an applet.
The first time the focus is on Applet, if I use (ALT + key) together, my menu is selected properly
If I press just ALT, IE menu gets the focus and now (ALT + key) stops working for my menu.
I have a JInternalFrame in the applet which internally contains JTable. If I select a cell in the table, (ALT+key) starts working but clicking on anywhere else on the internalframe doesn't help. Even clicking on a cell doesn't help the purpose of having keyborad shortcuts since mouse has to be used.
The related problem I get is that if the cell is selected in the table and I press (ALT + key), my menu item gets selected but also the cell goes in edit mode. I don't want this to happen and want to disable ell editing on ALt+keydown


IS there any way to circumvent this problem?

Please Help!!!
Rohini Juneja
Greenhorn

Joined: Aug 20, 2004
Posts: 2
I have checked the following message thread
http://www.coderanch.com/t/333649/GUI/java/mnemonics-Java-Applet


I understand, If I am not focussed on my applet, IE menus will be invoked.
But once I have the focus on my applet, the menus work only when I press ALT and the desired key (e.g S) together. If I press just ALT, the focus is lost from my applet. 'File' on IE menu is highlighted. If I do ESC, ALT+S doesn't work???
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Keyboard shortcuts for 'Menu bars in an Applet' not working!!