aspose file tools*
The moose likes Ranch Office and the fly likes Displaying non-ascii characters problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » This Site » Ranch Office
Bookmark "Displaying non-ascii characters problem" Watch "Displaying non-ascii characters problem" New topic
Author

Displaying non-ascii characters problem

David Balažic
Ranch Hand

Joined: May 15, 2008
Posts: 86
Hi!

In the login information (the bar below the moosefly.gif image) it says:
� Hello, David Balažic [ log out ]

(missing '�')

In the forum, it prints correctly "David Bala�ic"

Regards,
David
David Balažic
Ranch Hand

Joined: May 15, 2008
Posts: 86
Ah, I copied that over. It seems the codes are OK,just the font is missing the '�' character. Because it gets rendered as " David Balažic "

Hmm, now while writing the post the '�' is missing (copy&paste, just as before). Strange.

If I type '�', I see it. If I copy the text from the bar, '�' is not visible (that is I see "David Balaic" both in the bar and here where I type).
David Balažic
Ranch Hand

Joined: May 15, 2008
Posts: 86
"Hello, David Balažic"

Here is an image, since it might be hard to understand.

After I click "Add Reply", the above magically turns into David Balaic.

Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42906
    
  69
That is strange, but then, UBB (the software used for these forums) is quite dated, and this is not the only problem it has with non-ASCII characters.

The upside is that UBB's days here at the Ranch are numbered, and its replacement is bound to be much better in this area. So we're loth to spend time to investigate and fix problems that really are just display annoyances.

Please bear with us, it's not personal :-)
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Displaying non-ascii characters problem