• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

install and run tomcat3.1

 
Anonymous
Ranch Hand
Posts: 18944
  • 0
  • send pies
  • Quote
  • Report post to moderator
Could any one help me with the following problem?
After I finish all the settings according to the instruction of tomcat, when I dobuble-clicked on startup.bat icon, an DOS window was opened but not D:/JDK1.2.2, while I put the jdk1.2.2. I also got a message saying "Check logs\tomcat.log for error message". When I opened the tomcat.log file, I found the erroe message saying "The process cannot access the file because it is being used by another process". However, I can close the DOS window by dobuble-clicked on shutdown.bat icon.
Thank you in advance.
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13044
6
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
For one thing, you should be executing the startup.bat from an open DOS command window rather than clicking on the BAT file. Change to the tomcat\bin directory before executing the BAT file because it depends on that being the "current" directory. That way the window will stay open and you can better watch for errors.
If you are running under Win95 or Win98 you may get a message about running out of environment space, in which case you need to set the DOS window properties dialog Memory tab to a larger "Initial Environment" setting.
Bill
 
Anonymous
Ranch Hand
Posts: 18944
  • 0
  • send pies
  • Quote
  • Report post to moderator
Originally posted by William Brogden:
For one thing, you should be executing the startup.bat from an open DOS command window rather than clicking on the BAT file. Change to the tomcat\bin directory before executing the BAT file because it depends on that being the "current" directory. That way the window will stay open and you can better watch for errors.
If you are running under Win95 or Win98 you may get a message about running out of environment space, in which case you need to set the DOS window properties dialog Memory tab to a larger "Initial Environment" setting.
Bill

Thanks, bill.
I have done the using DOS command window, I am getting the same error. I was running it under NT server. The DOS command window stayed and I could got those messages mentioned above.
 
Anonymous
Ranch Hand
Posts: 18944
  • 0
  • send pies
  • Quote
  • Report post to moderator
What version of tomcat did you use and how did you set up the tomcat.bat file?
 
Anonymous
Ranch Hand
Posts: 18944
  • 0
  • send pies
  • Quote
  • Report post to moderator
The version is 3.1. In tomcat.bat file I have put in "set JAVA_HOME = D:\jdk1.2.2" and then I have put JAVA_HOME in the path. I didn't make any other change in the tomcat.bat file. What eles should I do?
 
Anonymous
Ranch Hand
Posts: 18944
  • 0
  • send pies
  • Quote
  • Report post to moderator
The message "Check logs\tomcat.log for error message" is always there no matter what. My guess is you did not have any problem. Try to run some code samples that come with tomcat to see how they work out. Use "http://localhost:8080/".Good luck!
 
Anonymous
Ranch Hand
Posts: 18944
  • 0
  • send pies
  • Quote
  • Report post to moderator
Originally posted by the sheik:
The message "Check logs\tomcat.log for error message" is always there no matter what. My guess is you did not have any problem. Try to run some code samples that come with tomcat to see how they work out. Use "http://localhost:8080/".Good luck!

Thanks Sheik. I will try it tonight and let you know if you are right. I think you are, though.
 
Anonymous
Ranch Hand
Posts: 18944
  • 0
  • send pies
  • Quote
  • Report post to moderator
Sheik, you are right. There was nothing wrong with my tomcat.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic