This week's book giveaways are in the Refactoring and Agile forums.
We're giving away four copies each of Re-engineering Legacy Software and Docker in Action and have the authors on-line!
See this thread and this one for details.
Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Install Tomcat

 
ricky gonzalez
Ranch Hand
Posts: 167
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, I have a problem installing Tomcat. Following the instruction given at
http://jakarta.apache.org/tomcat/jakarta-tomcat/src/doc/tomcat-ug.html#just_jserv
When I tried to set the environment variable to the root directory of JDK and add Java interpreter to my path
set JAVA_HOME=c:/jdk1.2
set PATH=%PATH%;%JAVA_HOME%\bin
I get a message "Too many parameters". Does anyone know what I did wrong?
Thanks in advance!
 
Madhav Lakkapragada
Ranch Hand
Posts: 5040
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Hi:
I did have this problem and resolved it.
set JAVA_HOME=c:/jdk1.2
Do you mean JAVA_HOME=C:\jdk1.2 ?
Try it out this may be the problem.
regds.
- satya
 
ricky gonzalez
Ranch Hand
Posts: 167
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks satya! I did try using backward slash, and the result is the same. Too many parameters. How did you resolve it? What parameters did I input? I am really terrible at DOS command. Thanks!
 
Madhav Lakkapragada
Ranch Hand
Posts: 5040
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am really terrible at DOS command.
well....u have my company there....
so, when you get this too many parameters
msg, what is the PATH? Also if possible could you
post your autoexec.bat file esp the PATH settings.
That may help me understand what u were trying to do.
set PATH=%PATH%;%JAVA_HOME%\bin
The reason I ask is I want to look at the current
PATH before your abv stmt gets exec.
In my case, I had two ; something like ;; in the
PATH and so it said too many parameters. watch out for such a thing.

regds.
- satya
 
ricky gonzalez
Ranch Hand
Posts: 167
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you satya! The following is my autoexec.bat:
set PATH=C:\PROGRA~1\ASTWORKS\MM\SPT;C:\PROGRA~1\ASTWORKS\HELPFI~1;%PATH%;"C:\DEV-C++\Bin\";C:\JDK1.3\BIN;
set PATH=%PATH%;%JAVA_HOME%\bin
set CLASSPATH=.;servlet_dir/servlet.jar;servlet_dir/jsp.jar
set TOMCAT_HOME=c:\tomcat
I tried to completely follow Tomcat's instructions but maybe I left out some details...
 
Madhav Lakkapragada
Ranch Hand
Posts: 5040
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by ricky gonzalez:
The following is my autoexec.bat:
set PATH=C:\PROGRA~1\ASTWORKS\MM\SPT;C:\PROGRA~1\ASTWORKS\HELPFI~1;%PATH%;"C:\DEV-C++\Bin\";C:\JDK1.3\BIN;

I see the problem
Get rid of the ; at the end of the abv stmt
in you autoexec.bat. Give it a shot and let me know.
Trust me, Tomcat is a good freely avail. piece of
software. And lot of companies use it even for commercial
purposes. Each month there are abt 10000++ downloads.
IMO, it helps to take the pain and learn how to use it.
After much hardwork, I am now able to use it and am
abt it.
Regds.
- satya
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic