• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

javax\servlet

 
Annette L'Heureux
Ranch Hand
Posts: 135
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi! Me again. Just wondering where I would find javax\servlet and javax\servlet\http.
I thought they were in the servlet.jar file, which my classpath points to. Am I missing a file?
Annette
 
srikanth b
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi ,
Can i know what u r using for servlet development,like the j2ee,or jsdk or tomcat.
Regards
srikanth
Originally posted by Annette L'Heureux:
Hi! Me again. Just wondering where I would find javax\servlet and javax\servlet\http.
I thought they were in the servlet.jar file, which my classpath points to. Am I missing a file?
Annette

 
nandkumar misal
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
you have to give path in your autoexec.bat file for the same
if you have insatlled jsdk2.1 then
the classpath to be given is c:\jsdk2.1\lib\jsdk.jar for servlets
and c:\jdk1.2\bin for javac
 
Annette L'Heureux
Ranch Hand
Posts: 135
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm using jsdk2.1, but I don't have a jsdk.jar file.
I've installed jsdk and set my classpath to c:\jsdk2.1\servlet.jar
I don't have a lib folder. It didn't install one.
I'm using NT, and my autoexec.bat file has nothing in it. It's completely blank.
All I really need are the class files for servlets. When I import javax.servlet and javax.servlet.html I get the error that they cannot find the path javax\servlet etc.
Any more ideas?
thanks,
Annette
 
Raukutam Sandeep
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi annette,
if u are using jdk1.2, there is no need to use jsdk at all.
I faced the similar problem a few days back, as u are facing now.
I have now overcome that problem.
Look for u'r servlet.jar file and, set the classpath to the jar file.
Now u won't jave any problem.
(i have overcome this problem by another method, not by setting the classpath).
If u have javawebserver, u can set the classpath like this,
set classpath=c:\javawebserver2.0\lib\servlet.jar;%classpath%

be sure to use this-> %classpath%, otherwise u'r autoexec.bat will be overwritten by this, and u won't find any other statements in that file.

try it, and get back!!!
Good luck!!
regds,
Sandeep.
 
srikanth b
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
In NT,u have to Right Click on My Computer,Click on properties,select the environment tab,there u have the classpath and path variables,update ur servlet.jar in the classpath,click the apply button on the corner,then restart the machine.hope this should update ur classpath.
regards
sri bha
Originally posted by Annette L'Heureux:
I'm using jsdk2.1, but I don't have a jsdk.jar file.
I've installed jsdk and set my classpath to c:\jsdk2.1\servlet.jar
I don't have a lib folder. It didn't install one.
I'm using NT, and my autoexec.bat file has nothing in it. It's completely blank.
All I really need are the class files for servlets. When I import javax.servlet and javax.servlet.html I get the error that they cannot find the path javax\servlet etc.
Any more ideas?
thanks,
Annette

 
Annette L'Heureux
Ranch Hand
Posts: 135
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks all. I've updated my classpath, and I don't know if I've rebooted that computer or not. Unfortunetly, we got a ton of snow last night and I'm snowed-in so I'll try it first thing tomorrow and let you know. Hopefully it is just a matter of rebooting!
I'll keep you updated, thanks again!
Annette
 
San Marathe
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
First let me know which javaserver u r using?
Check the classpath.It should contain a servlet.jar file.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic