aspose file tools*
The moose likes Servlets and the fly likes problem with localhost Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Java » Servlets
Bookmark "problem with localhost " Watch "problem with localhost " New topic
Author

problem with localhost

chandrika shankar
Greenhorn

Joined: Jan 30, 2001
Posts: 2
Hello,
I am trying out my first servlet program on jsdk2.1.
After I start JSDK2.1 server ,I tried to execute servlet by
typing http://localhost:8080 on Internet explorer 5.0
The error message I am getting for this is,

While trying to retrieve the URL: http://localhost:8080/
The following error was encountered:
ERROR 207 -- Cannot access the proxy-cache server through the URL that you entered.
This means that:
You may not use this proxy to connect to that url.
I went through similar questions posed by others,but I could not solve it.
So anyone of you,please help
Regards
chandrika

Abdul Samed
Greenhorn

Joined: Jan 29, 2001
Posts: 3
Hi Chandrika,
If that's the problem try setting the path and classpath system variables.
I assume JSDK2.1 directory on C drive
path=%path%;C:\JSDK2.1\bin;.;
classpath=%classpath%;C:\JSDK2.1\lib;.;
and after setting the these variables run 'servletrunner' utility from your dos prompt or from windows explorer. Then try to run your servlet class file.
Your class file should be in c:\jsdk2.1\examples OK
I hope this would solve your problem
-Abdul
Madhav Lakkapragada
Ranch Hand

Joined: Jun 03, 2000
Posts: 5040
hmmmmmm.......
I would first goto the Preferences, Advanced Options,
Proxy and check if the Proxy server is enabled.
If enabled, I would disable it using the option "Connect
directly to the Inernet
"
I don't mean to say that we cannot connect
to the localhost when proxies are on. I know
we can, I do use a proxy server.
$0.02.....
regds.
- satya

[This message has been edited by Madhav Lakkapragada (edited January 30, 2001).]


Take a Minute, Donate an Hour, Change a Life
http://www.ashanet.org/workanhour/2006/?r=Javaranch_ML&a=81
lokesh reddy
Ranch Hand

Joined: Sep 15, 2000
Posts: 66
Originally posted by Madhav Lakkapragada:
hmmmmmm.......
I would first goto the Preferences, Advanced Options,
Proxy and check if the Proxy server is enabled.
If enabled, I would disable it using the option "Connect
directly to the Inernet
"
I don't mean to say that we cannot connect
to the localhost when proxies are on. I know
we can, I do use a proxy server.
$0.02.....
regds.
- satya

[This message has been edited by Madhav Lakkapragada (edited January 30, 2001).]

Hi Madhav,
I agree with you, but why should we disable the proxy connection, instead we can turn on
Bypass a proxy server for local address
option.
You can find it in tools->options->connection->lansettings.
Bye.
Loke.
lokesh reddy
Ranch Hand

Joined: Sep 15, 2000
Posts: 66
Hi Madhav,
I agree with you, but why should we disable the proxy connection, instead we can turn on
Bypass a proxy server for local address
option.
You can find it in tools->options->connection->lansettings.
Bye.
Loke.
Madhav Lakkapragada
Ranch Hand

Joined: Jun 03, 2000
Posts: 5040
instead we can turn on
Bypass a proxy server for local address
option.You can find it in tools->options->connection->lansettings
.
Lokesh:
How could you run java appln's on IE when Microsoft
wants to stop Java support for its web browser...

regds.
- satya
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: problem with localhost