aspose file tools*
The moose likes Servlets and the fly likes setting servlet environment Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Servlets
Bookmark "setting servlet environment" Watch "setting servlet environment" New topic
Author

setting servlet environment

sunil chandwani
Greenhorn

Joined: Dec 20, 2000
Posts: 19

I have jdk1.2 installed on my PC. I have downloaded jsdk from sun's site. which resides in c:\jsdk2.0. I have set the path in autoexec.bat as c:\jsdk2.0\lib\jadk.jar;c:\jsdk2.0\bin. but till not working when tried javac compiler on sample servlet code. giving the error "javax.servlet not found in import." I have tried the same code with KAWA4.0 after setting the path there.But result is the same.javac is working fine with other jdk1.2 classes.like awt.,util.,etc.


Frank Carver
Sheriff

Joined: Jan 07, 1999
Posts: 6920
This is really a question more suited to the Servlets and JSP forum, so I've moved it.


Read about me at frankcarver.me ~ Raspberry Alpha Omega ~ Frank's Punchbarrel Blog
davidlong
Greenhorn

Joined: Jan 28, 2001
Posts: 21
Hi
This is not setting your classpath problem, which should be the dos environment setting on u machine, for example, your dos environment may not have enough memory to let u set classpath.
You may try this:
1. forget about setting classpath.
2. copy the servlet.jar to c:\jdk1.2(or jdk1.3)\jar\lib\ext. because in java 2 environment the classpath is not necessary all, sun privid that folder for replacing classpath.
hope this will help and pls tell me your result
David
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: setting servlet environment