aspose file tools*
The moose likes Servlets and the fly likes Trouble running apache Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Servlets
Bookmark "Trouble running apache" Watch "Trouble running apache" New topic
Author

Trouble running apache

clyde jones
Ranch Hand

Joined: Dec 02, 2000
Posts: 46
Hi all,
I'm new to trying to use apache. I have downoaded 1.3.1.9 and installed it on my win98 machine. From the instuctions to run apache, it says I should click "start apached as console", however I don't see this choice in my programs listing. When I click the apache icon, it looks like the console appears then quickly flashes away. Any help would be appreciated.
Thanks,
Clyde
Madhav Lakkapragada
Ranch Hand

Joined: Jun 03, 2000
Posts: 5040
i am assuming that you installed it thru the windows installer,
you know the stuff with msi files etc etc.......
Now if it comes up and immediately closes, I would think
the port may be busy. Are you running MS Personal Web server,
or something like that?
- satya
Maha: ofcourse. , thanks.

[This message has been edited by Madhav Lakkapragada (edited March 26, 2001).]


Take a Minute, Donate an Hour, Change a Life
http://www.ashanet.org/workanhour/2006/?r=Javaranch_ML&a=81
maha anna
Ranch Hand

Joined: Jan 31, 2000
Posts: 1467
Satya,
I assume you meant 'the port may be busy'.
regds
maha anna
Udayan Naik
Ranch Hand

Joined: Oct 18, 2000
Posts: 135
Hi Clyde.Mostly there is a problem with the configuration file(httpd.conf) of Apache.Open up a DOS Prompt and navgigate to the directory where the executable of Apache(Apache.exe , i assume) is placed.Run that exer through the DOS Shell.You will then be able to see the cause for Apache not running.
I hope that helps.
PS. Just an guess: I think it must be something to do with the 'ServerName' directive.


Udayan Naik<BR>Sun Certified Programmer for the Java 2 Platform
clyde jones
Ranch Hand

Joined: Dec 02, 2000
Posts: 46
Thanks All for responding.
Udayan,
I ran the apache.exe from the dos prompt and this is what I got:
C:\apache>apache.exe
APACHE.EXE: cannot determine local host name.
Use the ServerName directive to set it manually.
C:\apache>

I changed ServerName directrive of my httpd.conf to:
#ServerName "localHost" I tried it with and without the quotes.
Do I need to also edit the srm.conf and access.conf files? Any help would be appreciated.
Thanks,
Clyde
Madhav Lakkapragada
Ranch Hand

Joined: Jun 03, 2000
Posts: 5040

Personally, I would stay away from messing around with
the conf files. It has already worked for illions of
people, when it is done in the right way.
When I downloaded 3.1.19 from the binaries, I got the
wrong one first. We should not download from the binaries.
I downloaded the msi file for windows (which also needs the
windows installesr found on the same page for download).
Once the windows installer is in place, double clicking the
msi file will setup everything. I never had to do anything
with the .conf files.
The msi files can be found on this URL: http://httpd.apache.org/dist/httpd/binaries/win32/
I used the foll download:
apache_1.3.19-win32-no_src-r2.msi 02-Mar-2001 18:00 1.7M MSI Installer Package
The windowns installer program is found on the same page and I
used the foll:
Redistributable v1.10 for Windows 95 and 98 (already built into Windows ME) via http

When I did this, I had no problems, everything was taken care
by the setup. Ofcourse you can always customise your appache by
modifying the .conf files, if this is what your are trying to do.
regds.
- satya
Udayan Naik
Ranch Hand

Joined: Oct 18, 2000
Posts: 135
So Clyde,is Apache running normally after setting the 'ServerName' directive ? I think it should now,try sending a resquest to http://localhost/
and you should see the 'Test Page' provided with the Apache distribution.
I dont think you need to do anything with the other .conf files.
clyde jones
Ranch Hand

Joined: Dec 02, 2000
Posts: 46
Udanyan,
Thanks for your help. I don't think apache is running normally eventhough I changed the httpd.conf file. Apache still flashes at me. However, I will go to my browser and type http://localHost and see what happens. Madhav gave me a suggestion that I will also try tonight. When I downloaded Apache earlier, I did not download it from the page Madhav suggested I go to. Once again thanks for your help.
Clyde
clyde jones
Ranch Hand

Joined: Dec 02, 2000
Posts: 46
Madhav,
Thanks for telling me where to go to get the right apache. Was a little confused when I was asked to give a domain name, server name and e-mail address, but I guess this was needed to set up the conf files. I'll check it out tonight.
PS This is truly a friendly place.
Later,
Clyde
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Trouble running apache