File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Servlets and the fly likes How to change JRE version of JWS Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Make it so: Java DB Connections & Transactions this week in the JDBC forum!
JavaRanch » Java Forums » Java » Servlets
Bookmark "How to change JRE version of JWS" Watch "How to change JRE version of JWS" New topic

How to change JRE version of JWS

kiran mahavir
Ranch Hand

Joined: Jan 09, 2001
Posts: 35
Hello all,
I am using java web server 2.0 for my project.But it does not support methods like Double.parseDouble(),classes HashMaps,Sets etc which are available from JDK1.2 onwards.I came to know that JWS uses jre 1.1.7 which does not support classes as mentioned above.I need support for those classes.
So how to go about this.
Kindly give the reply at the earliest
with regards
Phil Hanna
Ranch Hand

Joined: Apr 05, 2001
Posts: 118
There is no reason to use outdated software. Download Tomcat from and set its JAVA_HOME environment variable to your JDK1.3 root directory.
Phil Hanna
Sun Certified Programmer for the Java 2 Platform
Author of :
JSP: The Complete Reference
Instant Java Servlets

Phil Hanna<BR>Sun Certified Programmer for the Java 2 Platform<BR>Author of :<BR><A HREF="" TARGET=_blank rel="nofollow">JSP: The Complete Reference</A><BR><A HREF="" TARGET=_blank rel="nofollow">Instant Java Servlets</A>
I agree. Here's the link:
subject: How to change JRE version of JWS
It's not a secret anymore!