my dog learned polymorphism*
The moose likes Servlets and the fly likes taomcat installation help Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Java » Servlets
Bookmark "taomcat installation help" Watch "taomcat installation help" New topic
Author

taomcat installation help

shabbir zakir
Ranch Hand

Joined: Nov 12, 2000
Posts: 183
hi!
I have installed tomcat on my computer.I have set the classpath and i have also set dos-properties to 4095.Still i am unable to open the first page of tomact when i start the server.It gives me error page not found.thanks in advance
kichu kichu
Ranch Hand

Joined: May 10, 2001
Posts: 59
Hai,
This is a reply that i had sent to another javaranch user who was facing problems with tomcat installation.
Please check out whether these are the steps you followed while installation.(The steps are below)
At the browser,if u type==>http://localhost:8080
u will get homepage if your installation has been proper.
This is the url of the site from which u can download tomcat.Download jakarta-tomcat-3.2.1.zip for win machines. http://jakarta.apache.org/builds/jakarta-tomcat/release/v3.2.1/bin/
The steps are
1)After you download tomcat from the net,U will get a zip file.
2)Extract that zip file to your drive eg D drive.U just need to right click the zip file and select the drive to extract it to.
3)Automatically a folder called jakarta-tomcat will be created in that specific drive.
4)Rename the folder to tomcat.
5)There will be a folder called webapps inside tomcat containing 4 war files.
6) Open up winzip and in this go to first war file and select extract to the same folder ie suppose the first war file is admin.war.create a new folder admin in webapps and extract contents of admin.war to it.similarily for all the other three files.
7)Go to environment variables in NT and 2000.set path as==>
TOMCAT_HOME with value Drivename:\tomcat
8)similarily set JAVA_HOME with value Drivename:\jdkx.x
here x.x being the version.
IF it is a 95 system set the above paths in autoexec.bat.
Now go to bin and run startup.
U will hopefully see a window popping up from which a new one will pop up.
Now u are up and running

Send a reply if u have nay queries.
jayram
Ranch Hand

Joined: Oct 30, 2000
Posts: 94
Just one correction ..u dont need to unzip war files present in the \webapps. When we start tomcat while deploying the apps it unzips them automatically
kichu kichu
Ranch Hand

Joined: May 10, 2001
Posts: 59
Yes joshi u are correct there.
Thanks for pointing it out.
regards,
kichu

[This message has been edited by kichu kichu (edited July 06, 2001).]
shabbir zakir
Ranch Hand

Joined: Nov 12, 2000
Posts: 183
hi!
thanks for ur reply.But still the same problem.It is giving the error page not found when i type http://localhost:8080 . Now what to do
shabbir zakir
Ranch Hand

Joined: Nov 12, 2000
Posts: 183
hi!
thanks for ur reply.But still the same problem.It is giving the error page not found when i type http://localhost:8080 . Now what to do
Rajakumar Makapur
Greenhorn

Joined: Jun 23, 2001
Posts: 13
Hi
if u start tomcat server using startup is tomcat is opening in other window. Otherwise just see the log file logs/tomcat.log
or go to server.xml and see where exactly your listener started, change to some other port and try.
regards
Rajakumar.
kichu kichu
Ranch Hand

Joined: May 10, 2001
Posts: 59
Hai,
Do you have any other webserver installed on your system?If yes,check whether that webserver is also using port 8080.
If this is the case thenchange the port settings for your tpmcat server in server.xml and try again.
regards,
kichu
shabbir zakir
Ranch Hand

Joined: Nov 12, 2000
Posts: 183
hi!
Thanks for ur reply.But i don't understand where to change the port.My tomcat server is openining in the different window.Now what to do.pls help
kichu kichu
Ranch Hand

Joined: May 10, 2001
Posts: 59
Hai,
Got to tomcat/conf folder.Inside it you will find server.xml file.Open it and you will find a line==>

<Connector className="org.apache.tomcat.service.SimpleTcpConnector">
<Parameter name="handler" value="org.apache.tomcat.service.http.HttpConnectionHandler"/>
<Parameter name="port" value="8080"/>
</Connector>

Change the port value 8080.Then try again.
Still if you are facing any problem,i will recommend you to install tomcat again using the steps that i have given to you before.
In the steps just ignore the step involving extraction of the war files.(U need not do that,they will be automatically done
)
Get back to me if u have any problems.

kichu
Ahmad Kamal Ramli
Greenhorn

Joined: Jul 12, 2001
Posts: 6
i follow the instruction given, and i identified that original port in server.xml is 8007 not 8080. i already changed it to 8080 and run it. the windows command display and show tomcat is running in new window. i try to access http://localhost:8080 or http://localhost:8007 but the problem still same, error page. before this i running ZOPE for windows in 8080 platform. but it only cause a problem if i running ZOPE and TOMCAT at same time . am i right .? give a suggestion
kichu kichu
Ranch Hand

Joined: May 10, 2001
Posts: 59
Hai,
See in the folder tomcat\webapps\ROOT.Look if index.html file is there.This is the page which gets displayed when we type==>hhtp://localhost:8080.
If this page is not there ,then you will get page not found.
Additionaly put a simple html page inside webapps\ROOT ,for example 1.html.
Then access it by typing==>http://localhost:8080/1.html
See if it is getting displayed.If yes,your tomcat is running properly.
try it and reply to me
kichu
Ahmad Kamal Ramli
Greenhorn

Joined: Jul 12, 2001
Posts: 6
file index.html is at webapps\root .. i alredy copy one html file and try method which you already suggested. but the problem is still same.. any other method you can help me ?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: taomcat installation help