aspose file tools*
The moose likes Servlets and the fly likes Tomcat is *almost* running Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Java » Servlets
Bookmark "Tomcat is *almost* running" Watch "Tomcat is *almost* running" New topic
Author

Tomcat is *almost* running

mansoor iqbal
Ranch Hand

Joined: Aug 14, 2000
Posts: 91
hello there mike ... i think u helped me out and i am just a few strokes shy of making tomcat run.....
the following is the batch file startup
the thing to note is the last line whihc is reproduced below:
***********************
Cannot find file 'c:\jdk1.2.2\bin\bin\java' (or one of its components).
***********************
WHERE IS MY MACHINE GETTING THE bin\bin path???...i have checked everywhere...i am not specifying this path anywhere...
-----------------------
C:\Program Files\Apache Tomcat 4\bin>
C:\Program Files\Apache Tomcat 4\bin>set _CATALINA_HOME=c:\Progra~1\Apache~1
C:\Program Files\Apache Tomcat 4\bin>if not "c:\Progra~1\Apache~1" == "" goto go
tCatalinaHome
C:\Program Files\Apache Tomcat 4\bin>"c:\Progra~1\Apache~1\bin\catalina" start
Using CATALINA_BASE: c:\Progra~1\Apache~1
Using CATALINA_HOME: c:\Progra~1\Apache~1
Using CLASSPATH: c:\Progra~1\Apache~1\bin\bootstrap.jar;c:\jdk1.2.2\bin\lib\
tools.jar
Using JAVA_HOME: c:\jdk1.2.2\bin
Cannot find file 'c:\jdk1.2.2\bin\bin\java' (or one of its components).
Check to ensure the path and filename are correct and that all
required libraries are available.
------------------
William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12682
    
    5
Just set JAVA_HOME to
c:\jdk1.2.2\
because it knows about bin and the other subdirectories.
Bill


Java Resources at www.wbrogden.com
mansoor iqbal
Ranch Hand

Joined: Aug 14, 2000
Posts: 91
thanks... it KINDA worked.... here is an error i get
------------------------
A nonfatal internal JIT (3.10.107(x)) error 'Relocation error: NULL relocation t
arget' has occurred in :
'org/apache/crimson/parser/Parser2.maybeComment (Z)Z': Interpreting method.
Please report this error in detail to http://java.sun.com/cgi-bin/bugreport.cgi
-------------------------
does that mean tomcat is now running?
Mike Curwen
Ranch Hand

Joined: Feb 20, 2001
Posts: 3695

Holy COW!

mansoor, you are having such a great time getting tomcat to run. Ok, I'm not laughing at you , but *with* you.

JIT is the 'just in time' compiler, and it looks like an internal error of some sort.

Crimson was Sun's XML parser, donated to apache. They have obviously incorporated some bits of it into Tomcat. Even though apache had their own Xerces parser at that point, they must have smushed them together. Who knows how these things work under the hood?

The way to determine if you have Tomcat running or not is to try to access it's index page. http://localhost:8080/

The issue with the JIT throwing this non-fatal error is a 'known' issue. I did a google search on "A nonfatal internal JIT (3.10.107(x)) error 'Relocation error", and it seems this is a well known error with some people's JIT compiler. Many products, from iPlanet, to Jive, to shrink-wrapped software have seen this problem before.

The best advice seems to be in this forum (which by the way, may at some point give UBB a run for it's money...it's Java-based). They suggest upgrading to jdk1.3
http://www.jivesoftware.com/jive/thread.jsp?forum=1&thread=2772
mansoor iqbal
Ranch Hand

Joined: Aug 14, 2000
Posts: 91
Hey Mike ... not worry about the laughing bit ... hell .. its my first tike setting up a server and all ... and if do make newbie mistakes or have funny errors ... well.... i wd be laffing too!...

anyway ... good news...
after the nonfatal error, the server DID start ...
how do i know this?.....a DOS java screen opens up which shows all the requests being made from the browser to the server.. the output is as follows:
-------------------
Starting service Tomcat-Apache
Apache Tomcat/4.0
StandardServer.await: Invalid command 'GET / HTTP/1.1' received
-------------------
in the output above lies yet another problem ...
every request i make, the tomcat gives me the last line as error
the above error is when i just type in : http://localhost:8080
no show ... nada ... i get the error and no page gets displayed.
tomcat says the the folder \webapps is the folder that is mapped as the virtual folder ... and the sub folder .\root has an index.htm file which says that if i can view this page i know tomcat is running...
i have also tried http://localhost:8080/webapps/root/index.htm
nope..nien .. niet ... the error i get is:
-----------------------
StandardServer.await: Invalid command 'GET /webapps/root HTTP/1.1' received
StandardServer.await: Invalid command 'GET /webapps/root/index.htm HTTP/1.1' rec
eived
-----------------------
stuck again ....

Mike Curwen
Ranch Hand

Joined: Feb 20, 2001
Posts: 3695

It is not really starting correctly. That 'non-fatal' error is probably involved.

Have you tried to upgrade your JDK to 1.3 or later?

Even though Tomcat docs say it can run with JDK1.2.x, I'd recommend upgrading to fix that non-fatal error. Let's eliminate that possibility before anything else.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tomcat is *almost* running
 
Similar Threads
still problems with tomcat
Need Help starting Tomcat
problem whith installation Tomcat
Tomcat 4.0 Configuration
tomcat 4.0 configuration