This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Servlets and the fly likes tomcat log file!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Servlets
Bookmark "tomcat log file!!" Watch "tomcat log file!!" New topic

tomcat log file!!

arpit singla
Ranch Hand

Joined: Jun 18, 2001
Posts: 66
I am trying to run tomcat with cloudscape embedded into it in school library computer. But it gives me following error:
Unable to open log file: C:\tomcat\logs\servlet.log! Using stderr as the defaul
Unable to open log file: C:\tomcat\logs\jasper.log! Using stderr as the default
i get follwing excptions:
:\tomcat/conf/tomcat-apache.conf (Access is denied) C:\tomcat/conf/tomcat-apache.conf (Access is d
at Method)
at org.apache.tomcat.task.ApacheConfig.execute(
at org.apache.tomcat.startup.Tomcat.generateServerConfig(
at org.apache.tomcat.startup.Tomcat.execute(
at org.apache.tomcat.startup.Tomcat.main(
Error generating automatic IIS configuration C
omcat/conf/iis_redirect.reg-auto (Access is denied) C:\tomcat/conf/iis_redirect.reg-auto (Access i
at Method)
the same combination works at my home. Please let me know what i am doing wrong here, could it be privilege problem. I tried to run as administrator in the lab, still gave me the same problem...
i am wondering if sth. needs to be configured.
arpit singla
Ranch Hand

Joined: Jun 18, 2001
Posts: 66
solved the problem i posted.. silly mistake !!
i was copying all my files from CDROM to Hard disk which had read only attribute so when i started my server, it wouldn't be able to write to log files..
I agree. Here's the link:
subject: tomcat log file!!
Similar Threads
Unable to Create Non-Read-Only Directories...
copy files from one folder to another in java
Unable to compile class for JSP
Tomcat Hangs during startup
Tomcat4.1.24 not working as a NT service??