• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Servlets on Weblogic Server

 
Rama Reddy
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am getting the 404 error ---
I installed the Weblogic 5.X app server and I am trying to test using a servlet example.
I did the following steps -
1. Installed the WEBLOGIC server.
2. In the weblogic.properties file I uncommented these two lines
weblogic.httpd.register.hello=\ examples.servlets.HelloWorldServlet
3. started the WLServer.
4.On the browser if I typed - http://localhost:7001/Hello
I am getting 404 error.
I checked the files"examples.servlets.HelloWorldServlet" and they are there.
5. Do I need to change the LAN settings.
6. I am using Windows 98.
Any help is very much appreciated.
Thanks
Rama
 
k swamy
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
weblogic.httpd.register.hello=\ examples.servlets.HelloWorldServlet
Call the servlet by http://localhost:7001/hello
Swamy
 
Tim Holloway
Saloon Keeper
Pie
Posts: 17989
47
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Don't use the backslash in filepaths. Outside the Windows world, it's an escape character that give you problems. ESPECIALLY if you code something like:
funny.directory=C:\foo\bar\
because the trailing backslash will be interpreted as a line-continuation request. Use forward slashes. Even though you're running WebLogic under Windows, WebLogic is using Java's filename parsing rules. Look at some of the filepaths that the WebLogic setup program created in your weblogic.properties file for examples.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic