wood burning stoves 2.0*
The moose likes Servlets and the fly likes Error 401 (Unauthrized) .... why ? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Servlets
Bookmark "Error 401 (Unauthrized) .... why ?" Watch "Error 401 (Unauthrized) .... why ?" New topic
Author

Error 401 (Unauthrized) .... why ?

Ayman Jaffar
Ranch Hand

Joined: Sep 06, 2000
Posts: 57
when I run start tomcat and then type
"http://localhost:8080/" I get Error 401 (Unautherized is displayed), why ??
I have a windows 2000 server O.S. and am loged in as administrator.
note: that I went to the links specified her to set up tomcat (java_home and etc.)
Is it me, or is there somethin' missin'


ayman.
[ June 19, 2002: Message edited by: Ayman Jaffar ]

america
Balaji Loganathan
author and deputy
Bartender

Joined: Jul 13, 2001
Posts: 3150
Can u check whether ur IIS webserver is running,if so stop it and try.
if still error persist,tell us what the steps u followed to install tomcat.


Spritle Software Blogs
Aleks V. Pascoal
Ranch Hand

Joined: Apr 21, 2002
Posts: 73
Probably your port is set to be other than 8080.
You can see that in the instaldir/conf/server.xml
Try to look for <Connector className="org.apache.catalina.connector.http.HttpConnector"
If it doesn't work try to look at
http://www.moreservlets.com/Using-Tomcat-4.html
See you
Anthony Villanueva
Ranch Hand

Joined: Mar 22, 2002
Posts: 1055
What sort of errors are cropping up in the log files?
Ayman Jaffar
Ranch Hand

Joined: Sep 06, 2000
Posts: 57
Result is :
I'm getting page cannot be displayed.
Okay, these are the steps
1- unzipped tomcat to the C:/ drive so that the folder of the "conf"
looks like C:/jakarta-tomcat-4.0.4/conf
2- set the PATH variable to C:/j2sdk1.4.0_01/bin and when I did "java -version" in the dos prompt it also worked as 1.4 etc...
3- created and set the JAVA_HOME = c:/j2sdk1.4.0_01
4- Turned on Servlet Reloading by adding <DefaultContext reloadable="true"/>
to the end of the paragraph specified in java Boutique.com and in other web sites.

5- double clicked on C:/jakarta-tomcat-4.0.4/bin/startup.bat
6- typed http://localhost:80/
then I get page cannot be displayed
thanks
[ June 22, 2002: Message edited by: Ayman Jaffar ]
[ June 22, 2002: Message edited by: Ayman Jaffar ]
William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12806
    
    5
It is very likely that the dialog box you are getting has nothing to do with Tomcat. The default Tomcat start page is plain html.
Bill
Ayman Jaffar
Ranch Hand

Joined: Sep 06, 2000
Posts: 57
It works,
I've got tomcat now and Servlets and JSPs are working.
I turned off the IIS service then I shut down and restarted tomcat.
and yes, your right, the dialog box (that asked for password and username) isn't related.
thanks to all.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error 401 (Unauthrized) .... why ?