Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

HelloWorld servlet not working

 
Frank Daly
Ranch Hand
Posts: 148
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
I am having problems using the HelloWorld servlet. I am using NT and tomcat 4.1.18.
my ..\root\web-inf\web.xml file is at the bottom of the page and I don't know why my servlet is not working!
any help greatly appreciated
Frank

<!DOCTYPE web-app
PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
"http://java.sun.com/dtd/web-app_2_3.dtd">
<web-app>
<display-name>Welcome to Tomcat</display-name>
<description>
Welcome to Tomcat
</description>
<!-- Servlet -->
<servlet>
<servlet-name>HelloWorld</servlet-name>
<display-name>HelloWorld</display-name>
<servlet-class>HelloWorld</servlet-class>
</servlet>
<!-- Servlet Mapping -->
<servlet-mapping>
<servlet-name>HelloWorld</servlet-name>
<url-pattern>/HelloWorld</url-pattern>
</servlet-mapping>
</web-app>
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13061
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you are addressing it with the /servlet/HelloWorld URL, you are running into the "invoker" servlet problem. There has been a run of these recently, browse through the last week of "my servlet doesn't work" messages.
Bill
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic