aspose file tools*
The moose likes Servlets and the fly likes Code has been working in Tomcat 4.1.27 but doesn't work anymore in 5.0.12 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Servlets
Bookmark "Code has been working in Tomcat 4.1.27 but doesn Watch "Code has been working in Tomcat 4.1.27 but doesn New topic
Author

Code has been working in Tomcat 4.1.27 but doesn't work anymore in 5.0.12

Mike Helmet
Greenhorn

Joined: Sep 26, 2003
Posts: 2
Hey.
Anyone can help me? Code has been working in Tomcat 4.1x but doesn't
work anymore in 5.0.12.
Error is coming from login_page.jsp. Struts 1.0 is in use ofcourse
Here is error code:

--------------------------------------------------------------------------------
HTTP Status 500 -
type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception
javax.servlet.ServletException: org.apache.jasper.JspCompilationContext.getTagFileJarUrl()Ljava/net/URL;
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:256)
javax.servlet.http.HttpServlet.service(HttpServlet.java:856)

root cause
java.lang.NoSuchMethodError: org.apache.jasper.JspCompilationContext.getTagFileJarUrl()Ljava/net/URL;
org.apache.jasper.compiler.ParserController.parse(ParserController.java:135)
org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:243)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:451)
org.apache.jasper.compiler.Compiler.compile(Compiler.java:437)
org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:508)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:291)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:301)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:248)
javax.servlet.http.HttpServlet.service(HttpServlet.java:856)

note The full stack trace of the root cause is available in the Tomcat logs.
----------------------------------------------------------------------------
Cheers and good weekend,
Mike
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Code has been working in Tomcat 4.1.27 but doesn't work anymore in 5.0.12