File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Servlets and the fly likes help in tomcat installation Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Java » Servlets
Bookmark "help in tomcat installation" Watch "help in tomcat installation" New topic
Author

help in tomcat installation

hemalatha gopinath
Greenhorn

Joined: Mar 09, 2004
Posts: 1
I have my jdk at c:\jdk1.3 and tomcat at c:\jakarta-tomcat-5.0.19
When I run startup in c:\jakarta-tomcat-5.0.19\bin from the windows98 environment it says �the JAVA_HOME environment variable not defined.this environment variable is required to run the program�
I opened startup.bat from MS-DOS and added to the top, �set JAVA_HOME= c:\jdk1.3�
I again run startup from windows.i get the message that �out of environment space� several times and also in the end �bad command or file name�
Please help me install tomcat.

--------------------------------------------------------------------------------
Jeroen Wenting
Ranch Hand

Joined: Oct 12, 2000
Posts: 5093
upgrade your OS to something that can cope with the larger amount of environment space required.
Windows 98 doesn't cut it, it's way too old and out of support...


42
William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12769
    
    5
Win98 can run Tomcat just fine, you just have to change the setting in the DOS Console window that allocates space for environment variables. Tomcat does a LOT of fiddling with environment variables and the default value is too small.
Go to the Javaranch forum specifically for Tomcat and search older posts for Win98.
Bill
kriti sharma
Ranch Hand

Joined: Feb 16, 2001
Posts: 160
STRANGE!!!looks like you have copied my message,
anyways here is the answer.
right click on the startup.bat file ,go to properties->memory->initial environment and make it 2816 from auto.now run the bat file.it will work
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: help in tomcat installation