wood burning stoves 2.0*
The moose likes Servlets and the fly likes webapps can't auto deploy directory Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Servlets
Bookmark "webapps can Watch "webapps can New topic
Author

webapps can't auto deploy directory

Parka Teoh
Ranch Hand

Joined: Aug 28, 2004
Posts: 40
When I create a new sub directory in webapps/, doesn't the directory get deployed automatically?

This is what I have...
I'm suppose to get my index.htm when I type "http://localhost/root2/index.htm", but I don't.

I don't know what's amiss.



Do you have a parka?<br /> <br /><a href="http://sg.geocities.com/inschooool" target="_blank" rel="nofollow">Visit my homepage</a> | <a href="http://parka.deviantart.com/" target="_blank" rel="nofollow">Parka Deviantart gallery</a>
Sonny Gill
Ranch Hand

Joined: Feb 02, 2002
Posts: 1211

Parka,

You may want to post more details -
What App server you are using, 'auto deploy' varies a lot among different application servers.
What output do you get on the console when you start up the server? It may show an exception being thrown while loading the webapp.
The actual directory structure on your file-system. The image you posted appears to be out of Dreamweaver, if I am not mistaken.


The future is here. It's just not evenly distributed yet. - William Gibson
Consultant @ Xebia. Sonny Gill Tweets
Parka Teoh
Ranch Hand

Joined: Aug 28, 2004
Posts: 40
Hi,

I solved my own problem after much fustration.

Apparently, if there is wrong link in the FORM ACTION, it will render the whole page unloadable (can't be found).

I edited my index.htm's FORM ACTION and it works now. Didn't realise that before. My previous FORM ACTION wasn't able to find the processing servlet because of some linking address error...

 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: webapps can't auto deploy directory
 
Similar Threads
tomcat running but gives an Invalid HTTP get error
SCJD development team accepts new member again!
Where to place - under webapps or ROOT ?
jforum installation/configuration
Tomcat is *almost* running