• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Filter Mappings - URL Pattern

 
Shijo Joseph
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello

I have <uri-patter>xyz.do</uri-pattern>

When I change like this, Tomcat is not even picking *.do mapping

<uri-patter>/xyz.do</uri-pattern>

This case, everything else, other than works fine.
I mean, Tomcat is not executing the filter.

I tested the same scenario in Weblogic also.
But there is also filter not working.

Since i use the same filter in more than one(e.g. /xyz/xyz.do and
/pqr/xyz.do) applications, I like to put the same mapping so that both the subfolders use the same mapping.

Will u pls give a clue to the problem?

Thanks in Advance

Regards
Shijo Joseph
 
Shijo Joseph
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's <url-patter>xyz.do</url-pattern>

Sorry, I put it as uri pattern.


Thanks & Regards
Shijo Joseph
 
Sonny Gill
Ranch Hand
Posts: 1211
IntelliJ IDE Mac
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Shijo Joseph:
It's <url-patter>xyz.do</url-pattern>



You have an 'n' missing there - <url-pattern>xyz.do</url-pattern> ,
or was that just a spelling mistake when you typed?
 
Shijo Joseph
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Again it is spelling mistake.
I tried to put an extract from my working settings.

I am trying for some optimizations, and scale down the number of entries in the web.xml filter mapping entires, so that it remain simple.

Hope somebody can help me out

Thanks & Regards
Shijo Joseph
 
Shijo Joseph
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This Problem still exists for me
Anybody have any clue on it?

Expecting a response

Thanks & Regards
Shijo Joseph
 
Heonkoo Lee
Ranch Hand
Posts: 85
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you are using Struts, you probably have ActionServlet mapping in web.xml. Then, try something like this:



This will cause the filter to intercept all the http request url mapped to the action servlet (*.do).

Hope this helps.

Regards,
[ April 03, 2005: Message edited by: Heonkoo Lee ]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic