Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

what problem is this???

 
Nicky Eng
Ranch Hand
Posts: 378
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator



when i compile the "BeerExpert.java", every path was correct, but after compile it, it give me something like this :





what is that means??? anyone know??? what is the solution??
 
David O'Meara
Rancher
Posts: 13459
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I believe this is a warning about a new JDK 1.5 feature, warning you that you are not using generics. Don't worry about it for now.
 
Nicky Eng
Ranch Hand
Posts: 378
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi

so it was okay to leave it like that?
 
SunilRee Gupta
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Same Code I have compiled in java version 1.4.2_04. I did not get any warning, note etc.

It seems it just Note, probably yu can ignore it.
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, you can either ignore it or use Generics on you Collection. Like



Then you no longer will get warnings.

Mark
 
Nicky Eng
Ranch Hand
Posts: 378
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi,

thanks all....

my this problem solved.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic