Win a copy of The Java Performance Companion this week in the Performance forum!
    Bookmark Topic Watch Topic
  • New Topic

deploy xplanner in Websphere5.1

 
Dhruva Srivastava
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Report post to moderator
Hi all,

If any of you have used xplanner you might be knowing that it works well on Tomcat(version 4.1 and above). I downloaded war file of xplanner and successfully deployed it on Tomcat 4.1.
Then I tried to deploy same war file on Websphere Application Server 5.1, but it was throwing some deploy time exceptions, I figured out the problem, web.xml has a entry of "servlet-mapping" element without having any corresponding "servlet" element i.e,:- it has the following servlet-element:-

"servlet-mapping"
"servlet-name" jsp "servlet-name"
"url-pattern" *.jspf "/url-pattern"
"servlet-mapping"

without any corresponding "servlet element"

I removed this element from web.xml and renamed all *.jspf files(there were only two) to *.jsp. After that xplanner was deployed on WAS 5.1 but some of its pages started to show JSP Processing Error. [banghead]

But in case of Tomcat i made no changes in war file and then also it was working without any error

Can anyone help me with the above problem?

Regards all
Dhruva
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34671
367
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Report post to moderator
Dhruva,
Please don't post the same question in multiple forums. It makes it harder to follow the conversation.

And welcome to JavaRanch!

Thanks,
Jeanne
Bartender
 
Don't get me started about those stupid light bulbs.
    Bookmark Topic Watch Topic
  • New Topic