• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

UnsatisfiedLinkError

 
saikrishna cinux
Ranch Hand
Posts: 689
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i am getting this error in tomcat5.0

but it is working fine in tomcat4.0


this is the exception stack trace


type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: Invoker service() exception
org.apache.catalina.servlets.InvokerServlet.serveRequest(InvokerServlet.java:477)
org.apache.catalina.servlets.InvokerServlet.doGet(InvokerServlet.java:133)
javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)


root cause

java.lang.UnsatisfiedLinkError: no ocijdbc8 in java.library.path
java.lang.ClassLoader.loadLibrary(ClassLoader.java:1517)
java.lang.Runtime.loadLibrary0(Runtime.java:788)
java.lang.System.loadLibrary(System.java:834)
oracle.jdbc.oci8.OCIDBAccess.logon(OCIDBAccess.java:209)
oracle.jdbc.driver.OracleConnection.<init>(OracleConnection.java:198)
oracle.jdbc.driver.OracleDriver.getConnectionInstance(OracleDriver.java:251)
oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:224)
java.sql.DriverManager.getConnection(DriverManager.java:512)
java.sql.DriverManager.getConnection(DriverManager.java:171)
com.vlms.misc.MainServlet.getConnection(MainServlet.java:50)
com.vlms.vts.grandtest.gre.qndisplay.GreAwaDisplay.doGet(GreAwaDisplay.java:58)
javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
org.apache.catalina.servlets.InvokerServlet.serveRequest(InvokerServlet.java:419)
org.apache.catalina.servlets.InvokerServlet.doGet(InvokerServlet.java:133)
javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)


note The full stack trace of the root cause is available in the Apache Tomcat/5.0.28 logs.


--------------------------------------------------------------------------------
 
ramprasad madathil
Ranch Hand
Posts: 489
Eclipse IDE Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When you migrated your application from tomcat 4.0 to 5.0, did you copy the additional libraries in common/lib over to 5.0. Specifically the jar files that the server complains about?

ram.
 
saikrishna cinux
Ranch Hand
Posts: 689
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
yes, i have copied all the jar files from tocamcat4.0 to tomcat5.0 ...\common\lib folder

still it's showing same error

please give me some best solution
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Double check that it's there and that it wasn't corrupted in the process of moving it.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic