This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Servlets and the fly likes servlet not loading Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Servlets
Bookmark "servlet not loading" Watch "servlet not loading" New topic
Author

servlet not loading

Anand Shrivastava
Ranch Hand

Joined: Jul 22, 2007
Posts: 125
i am running tomcat6.0.13.
i have made a connectionservlet of package table and compiled it and stored it in the ROOT directory.
when i give the following URL http://localhost:8180/servlet/table.connectionservlet
tomcat returns the following error -
type Status report

message /servlet/table.connectionservlet

description The requested resource (/servlet/table.connectionservlet) is not available.
Apache Tomcat/6.0.13

I have also tried to copy this file to WEB-INF/classes/table directory and then give the following URL http://localhost:8180/WEB-INF/classes/servlet/table/table.connectionservlet
still i get the same error.

Kindly help.


Anand Shrivastava
SCJA
Ben Souther
Sheriff

Joined: Dec 11, 2004
Posts: 13410

Recent versions of Tomcat do not allow direct access to servlets by default.
You'll need to configure a servlet entry and a servlet mapping in your deployment descriptor (web.xml).

The component that allowed this was called the InvokerServlet.
It's still in Tomcat but its configuration settings have been commented out.
To learn why, go here.
[ August 16, 2007: Message edited by: Ben Souther ]

Java API J2EE API Servlet Spec JSP Spec How to ask a question... Simple Servlet Examples jsonf
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: servlet not loading
 
Similar Threads
Beginner's, servlet problem
servlets and new web directory
Apache/Tomcat URL Mapping
Can't get book example to work
strange 404 problem