Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem running Servlet

 
mithun gooty
Ranch Hand
Posts: 33
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Whenever i try to run the following servlet i dont the get output in the current window, instead it displays the following message "Do you want to save?". Each time i need to save to a local folder, double click and open it with the internet explorer. I am using Tomcat5.5.



All the servlet does is take a string and vertically transpose, and display it as an image. Can anybody give the reason as to why this is happening?
 
Adeel Ansari
Ranch Hand
Posts: 2874
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How about if you click any image link from your browser? Does it ask to save? I mean, is it asking to save the url below?

http://us.i1.yimg.com/us.yimg.com/i/pulse/07q4/pulse_nissan-gtr139x119.jpg
 
Ulf Dittmer
Rancher
Posts: 42967
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think the proper content type is "image/jpeg", not "image/jpg".
 
mithun gooty
Ranch Hand
Posts: 33
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hey thank you very much Ulf. I made the changes according to your comments and now its working fine.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic