File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Java in General and the fly likes BDK1.1 problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Java in General
Bookmark "BDK1.1 problem" Watch "BDK1.1 problem" New topic

BDK1.1 problem

Howard Ralston
Ranch Hand

Joined: Jun 25, 2001
Posts: 105
Howdy folks,
Yesterday I installed BDK1.1 and tried to run some examples from one of my books. I have two problems:
1. Some of the beans are not available in the ToolBox. There are no button beans.
2. I tried to put a TickTock bean and a Molecule bean in the BeanBox and have the Molecule rotate when the timer fired a propertyChanged event. When I select OK I get the message "Generating and compiling adapter class", but nothing happens.
Is anyone familiar with these problems?

<a href="" target="_blank" rel="nofollow">Free local coupons</a>
Jessica Sant

Joined: Oct 17, 2001
Posts: 4313

did you install the BDK into a directory that has spaces in the path? -- like C:\Program Files\BDK ??
If so, reinstall it to a directory that does not contain spaces and try again.

- Jess
Blog:KnitClimbJava | Twitter: jsant | Ravelry: wingedsheep
Howard Ralston
Ranch Hand

Joined: Jun 25, 2001
Posts: 105
Thanks Jessica,
That solved the compilation problem like a charm. However I still cannot get the Button beans to load from buttons.jar.
I will play with it and see what I come with.
Thanks again.
I agree. Here's the link:
subject: BDK1.1 problem
It's not a secret anymore!