Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Generics {probably wrong forum}

 
Nick George
Ranch Hand
Posts: 815
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
sorry for the wrong forum, but I'm not really sure where to put this, and it is a one-word answer.

Once I upgrade to 1.5, whenever it comes out, will the following be legal?

or are generics mandatory?
 
Stefan Wagner
Ranch Hand
Posts: 1923
Linux Postgres Database Scala
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
warning
 
Dirk Schreckmann
Sheriff
Posts: 7023
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This forum is fine for such a question.

Yes, it will be legal, just as it is today with Java 1.4.

As mentioned, the compiler will issue a warning.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic