A friendly place for programming greenhorns!
Big Moose Saloon
Register / Login
Java in General
Naming method which returns boolean
Joined: May 26, 2004
Jun 13, 2005 02:29:00
I have a method which returns boolean .see bellow
public boolean getDigitalPhase()
Which is a good naming for this method
Joined: May 09, 2005
Jun 13, 2005 02:39:00
isDigitalPhase() should be the correct one, if you'd like to follow naming conventions
Joined: Jan 29, 2003
Jun 13, 2005 07:25:00
You'll see some other grammatical constructs from time to time ...
A good question is never answered. It is not a bolt to be tightened into place but a seed to be planted and to bear more seed toward the hope of greening the landscape of the idea. John Ciardi
Joined: Feb 18, 2005
Jun 13, 2005 08:10:00
Originally posted by Stan James:
...or just about any phrase using (singular) "present tense" verbs.
So getHeight() would return an int or float, but getsHeight() would "obviously" return boolean.
I agree. Here's the link:
subject: Naming method which returns boolean
How Do We Know that We Add Duplicate to a Set and Add Duplicate Key to a Map
checkPermission without SecurityException?
fetch values from one package into another package
All times are in JavaRanch time: GMT-6 in summer, GMT-7 in winter
| Powered by
Copyright © 1998-2014