File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Java in General and the fly likes Please confirm Code works with certificate Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Java in General
Bookmark "Please confirm Code works with certificate" Watch "Please confirm Code works with certificate" New topic
Author

Please confirm Code works with certificate

Taco Fleur
Greenhorn

Joined: Jul 11, 2005
Posts: 21
I have been battling with an issue for more than 3 weeks now, a week ago I contacted the vendor for support and am paying them for it.
Basically what I told them was, I can get this code to work from the command line, but when I call the class via your application server I get an error.
Well, today while on the phone with them I deleted all certificates from my keystore and tried to import it again, and I have not been able to get it working again, which is making me look very bad as they have spend lots of time on it.

My question to you is, can someone please verify that they can get the code working with the certificate? Even willing to pay a little money to get this done..

I know very little about Java and SSL, so if you see something thats not right let me know.

The vendor sent me the following link http://edge1.asic.gov.au/edge/test/EIS_CAcert.pem and they also send me some .key files which at one stage I had seperated and imported.
I am assuming who ever is willing to help out needs the key files, so I posted them here:
www.shelco.com.au/test/edge/Shelco.key.der
www.shelco.com.au/test/edge/Shelco.cert.der

The code is:

Once again, at this stage I am interested to see if someone can get this going from the command line without getting the error "Certificate not found", and then I am interested in seeing step by step how you got it working.

many thanks in advance..
[ August 01, 2005: Message edited by: Jim Yingst ]
Taco Fleur
Greenhorn

Joined: Jul 11, 2005
Posts: 21
oops forgot to signup for "Email Notification"..
Jim Yingst
Wanderer
Sheriff

Joined: Jan 30, 2000
Posts: 18671
Also you forgot to include [code] tags. Unindented code is painful to read. I have edited your post to put in the code tags and preserve your indentation. Unfortunately you also have several overly long lines which impede readability (see how the whole page is forced to be the width of your longest lines?). I have inserted some line breaks into the worst offenders, but many lines are still too long to be readable, I think. Also in several places the indentation is nonsensical (which may be why it was omitted in the first place). And, really, the whole thing is too long for me to want to take time to analyze it carefully to see what's going on. Isn't it possible to reduce this code to a small portion which is actually throwing the error? OK, it's true that if you make it too small we'll probably turn around and ask for more code as context. But right now there's just too much... stuff there. Perhaps someone else will want to carefully analyze it, but for me it's late and I'm about to go to sleep, so I only have time to criticize your formatting. Note that you can edit your post using the little pencil-and-paper icon near the top of the post. Cheers...
[ August 01, 2005: Message edited by: Jim Yingst ]

"I'm not back." - Bill Harding, Twister
Taco Fleur
Greenhorn

Joined: Jul 11, 2005
Posts: 21
Point taken - tried to edit the code, but there really is not much I can delete, except comments.

If someone would look at this I would think they would just copy and paste it into their favourite IDE.
Taco Fleur
Greenhorn

Joined: Jul 11, 2005
Posts: 21
PS. those really long lines really cannot contain a space otherwise the message would be invalid and the test would not work.
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

They needn't contain a space, but have to be broken manually like this:


The 4. line in the main seems already corrupted - it's ending without """ after 'this is the name'.
May you overlook your posting.

[ August 01, 2005: Message edited by: Stefan Wagner ]

http://home.arcor.de/hirnstrom/bewerbung
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Please confirm Code works with certificate