Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Agile forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Help with installing SDK1.2.2

 
Thomas Jav
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hello
I've installed SDK on my computer (OS win2000)but there is something wrong
when I run this command:
C:\>javac HelloWorld.java
I recieva a message:
' javac' is not recognized as an internal or external command, operable program or batch file.
I went through the whole troubleshooting process suggested by Sun and nothing has changed.
I did not have previously any exposure to writing commands in dos prompt so mayby there is somthing wrong with the syntax of that command (no space or backslash?)
 
Hugues Tremblay
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,
It depends on where you've installed it, but let's say you installed it in c:\. Normally, if you didn't changed parameters while installation was running, you should have a directory that is created for it. (something like c:\jsdk1_2)This is the java home. So the program javac.exe should be in c:\jsdk1_2\bin. So, to execute javac, you have to specify the path so your command line would be something like:
c:\jsdk1_2\bin\javac HelloWorld.java
it should work (note that you might have to change jsdk1_2. It might not be exactely how Sun define it but I don't remember the sun's default nomenclature because I usually change it to c:\jdk )
STEP 2
As you can see, it can be long to always write the path to compile, so you can set the variable PATH in your environnement setting to the path so you won't have to always write it!
Hope it help, despite my pour eglish ;-)
Hugues
Originally posted by Thomas Jav:
hello
I've installed SDK on my computer (OS win2000)but there is something wrong
when I run this command:
C:\>javac HelloWorld.java
I recieva a message:
' javac' is not recognized as an internal or external command, operable program or batch file.
I went through the whole troubleshooting process suggested by Sun and nothing has changed.
I did not have previously any exposure to writing commands in dos prompt so mayby there is somthing wrong with the syntax of that command (no space or backslash?)

 
Paul Smythe
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You need to set the path variable for your system. If youre using Windows, this is a good one: http://www.geocities.com/ezt_howto_installjsdk/
For Linux:
http://www.geocities.com/tipsforlinux/articles/11.html
 
James Chegwidden
Author
Ranch Hand
Posts: 201
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Why are you installing 1.2? The current version is 1.4.
 
Bideshi Guy
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Seems like you need to set up Environment variables, It should be in the properties of mycomputer under advance option.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic