aspose file tools*
The moose likes Beginning Java and the fly likes Applet runtime error - please help... Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "Applet runtime error - please help..." Watch "Applet runtime error - please help..." New topic
Author

Applet runtime error - please help...

Elisabeth Katsavras
Greenhorn

Joined: Aug 07, 2001
Posts: 5
Hi, I would be really grateful if someone can point me in the righ direction. I am trying to write an Applet - when I compile it everything seems fine. However when I try to run it in AppletViewer I get this error:
-----------------------------------------------------------
java.util.MissingResourceException: Can't find resource for bundle sun.applet.resources.MsgAppletViewer, key appletpanel.badattribute.exception
--------------------------------------------------------------
Does anyone know what this is about or how to fix it?
Thanks
Eli
Lucas Richardson
Ranch Hand

Joined: Jul 08, 2001
Posts: 32
Does it work in a browser? Does any other applet work in the appletviewer? It might just be the appletviewer itself...
Elisabeth Katsavras
Greenhorn

Joined: Aug 07, 2001
Posts: 5
Thanks for replying...
The Applet that gets the above error message works in a browser (only partially as I haven't finished it yet) and I have tried other (simple) Applets and they don't get this message.
I've tried rebuilding it from scratch but I get the error when I reach a certain point and I can't seem to back from this point.
I'm wondering if it could be something to do with the Applet being a JApplet or whether it concerns the 'Submit' button, as when this is hit the applet has to access files on the server (I have changed the permissions, but perhaps not correctly?
These are my guesses?
Elisabeth Katsavras
Greenhorn

Joined: Aug 07, 2001
Posts: 5

I should have been using absolute numbers, rather than percentages, for the width and height attributes in the HTML file. Percentages worked fine for the browser but not for appletviewer! Thus, the MissingResourceException...
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Applet runtime error - please help...