Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
The moose likes Beginning Java and the fly likes compiler still not working Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "compiler still not working" Watch "compiler still not working" New topic
Author

compiler still not working

jim, valenta
Ranch Hand

Joined: Mar 16, 2001
Posts: 47
Hi,
Some time ago I installed JAVA 1.3 jdk and my compiler was working fine. I got a bvirus and wipped out everything. I reloaded everything but now my compiler doesnt work. I had this problem once in the past and I just reloaded the jdk and it worked fine but this time I have reloaded both the 1.3 and 1.4 beta (have both on now but have tried it with just the 1.4)and it still wont work.
If you have any suggestions. Thanks in advance.
Ps. Want to mention that when I type java at the command prompt and just the file name without any extensions it runs fine. When I run javac I get Bad command or file name.
jim
[This message has been edited by jim, valenta (edited October 03, 2001).]
Paul Stevens
Ranch Hand

Joined: May 17, 2001
Posts: 2823
Is javac in the bin directory of the jdk? Is that directory in your path?
jim, valenta
Ranch Hand

Joined: Mar 16, 2001
Posts: 47
yes
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: compiler still not working
 
Similar Threads
Project facet Java 5.0 is not supported by target runtime Apache Tomcat v5.5
eclipse, ant, and Java versions
Can't run JDK outside JBuilder7 after install
Can't run simple class with 1.4 method
compiling code using different versions (jdk 1.3 and jdk 1.4)